FP2 doesn't connect to Win 10 / problems with USB

Problem:
I replaced my bottom module, booted my FP2, unlocked it and connected it with my Win 10 PC via USB. I had a stable connection - but only one time. After that each attempt to connect both devices failed. The windows device manager says: Unknown USB device (error when requesting a device description).

Attempt 1:
I downloaded Google USB drivers (Obter o driver USB do Google  |  Desenvolvedores Android  |  Android Developers), opened the device manager, made a right click on the yellow marked device and tried to install the driver manually. The device manager offers only one driver for an unknown device. I installed it. But the USB connection still does not work.

Attempt 2:
I booted FP2 in fastboot mode. The windows device manager shows an unknown Android device. I installed a driver, using the downloaded Google USB drivers. Windows recognizes an Android device. I have a stable connection. I can reinstall the FP operation system (https://support.fairphone.com/hc/en-us/articles/360042185512-FP2-Manually-update-with-Windows). When I shutdown from fastboot mode and boot the FP2, everything works fine. But I cannot connect the phone via USB to the PC.

Result:
My cable is working, the USB port works in the fastboot mode, but not in the normal mode. When I install my old bottom module (with broken microphone), the USB connection works.

The new module is from Switzerland, whereas I live in Germany. Are there any local restrictions?

I am using the fp2-A9-gms-21.12.0-rel.1 and Windows 10 Pro. USB debugging it enabled. The Android Debug Bridge (ADB) is installed.

Welcome to the Community Forum :+1:

Just to make sure: You chose “File Transfer” on your FP2 after connecting it to your computer via the cable, didn’t you?

Other than that: Have you rebooted Windows in between attempts to connect the FP2?

1 Like

Hi jhf and welcome.
I experienced a similar problem.
I advise you to update the Windows driver, through the standard Windows update facility. See here:

1 Like

Now it works! Problem solved!

I took a look into the FP2 settings. The standard for USB connection was already “File transfer”. I did not change it. After that I connected the FP2 to the PC again. Suddenly a dialog opened and told me that MTP is going to be installed. Now I have access to the phone. In the device manager I see an USB device called ADB interface.

I really don’t know how this problem was solved. Just by opening the settings?

Anyway, thank you a lot!

2 Likes

And the problem returned, after I unplugged the phone and reconnected it. Maybe there is a loose contact. I don’t know.

Try a good cable then. I have a pair of good cables which hold really tight in the usb-slot, so I never had problems with these. But a lot of other cables fail on my FP2…