FP2 does not turn on

Yesterday I completely drained my battery until the phone shut off. Now the phone would not turn on again. When connected to a power source, the LED in the top left corner would blink, but even after several hours I’m unable to turn on the phone.
I’m aware that the Fairphone is picky with chargers and cables, and I tried 3 different cables and power sources which worked flawlessly the last 3 months.
When I connect the FP2 to a power source without the battery inserted, the phone would start to boot (showing the screen reading ‘Fairphone’ and vibrate) but then cancelled the boot and repeat this over and over again. So I would be interested if it is possible to boot the FP2 completely without the battery. If it was possible, then I’m sure that something except for the battery is broken.
I also would appreciate further suggestion how to solve this, but my impression so far is that I will have to send it in.

1 Like

A post was merged into an existing topic: FP2 Won’t turn on or charge