FP2 does not start after update

The Fairphone screen plus blinking blue light is the so-called fastboot or bootloader mode (reached by pressing Vol. down during boot).
Which is the correct mode for the manual installation, if you’re following https://support.fairphone.com/hc/en-us/articles/207914363


I’ve got the same problem as Katrin_S: restart doesn’t get past blue dots below “Change is in your hands” …
I did get into recovery mode, though. But when I try rebooting it says “No OS installed!” - so I’m hesitant to proceed.
Any advice? (apart from manual installation of the update)

[@AnotherElk] Thanks. Didn’t work out though:
Reboot > System gets stuck in FairPhone logo & blue dots, same as with restart.

(And: is it possible to back up, at least partly, when you can’t change the USB connection with the computer from charging into “file transfer”, as the phone isn’t working??)

Hello, same problem happens to me.

The download of the package was ok.
When hitting (4 or 5 times) the RESTART button inside of the updater app nothing happened.
I closed the updater, reopened, downloaded the OS update and hit restart. Went fine.

The phone rebooted, I left it apart.

After 30 min I checked the state of the update and found the phone stocked [at a screen like this one] which appears to be the TWRP (https://forum.fairphone.com/uploads/default/original/2X/0/02fa5f3a67356e8f746e85b13356b398f3e8892d.png) .

If I reboot the phone is stocked at the very first loading screen (FAIRPHONE POWERED BY android).

Do I have to wipe everything?

Not yet.

And if that failed, there would still be the manual install method …

Thanks for the reply.

if I go to the TWRP screen and look for the .zip you mentioned:

hope fp_update_gms_whatever.zip is still there to select.

there is none :frowning:

If I try to wipe from the TWRP it fails, I get a red error that says:

unable to find partition for path '\system'


Full SELinux support is present.
Formatting Cache using make_ext4fs...
Formatting Data using make_ext4fs...
Updating partition details...


I take a look to the manual installation.

As irritating as it is, this message was observed to be kind of a feature, not a bug, of the older TWRP version bundled with Fairphone’s OSes.
If you don’t like it, you can install a more recent TWRP from twrp.me.
The proven most trouble-free version there would be 3.2.3-0.

Looks like you did the TWRP factory reset. Why? Now your data is gone.
The manual install method wouldn’t have done this, as you will read now, I guess …

I couldn’t find any old versions of the image on my phone after I hit the issue…

Downgrading with adb sideload works perfectly, no loss of data or other issues whatsoever.

A fix for the issue is on the way, it just hasn’t been merged yet:


Yes, I eventually figured out that all my important stuff is on cloud services! :slight_smile:

1 Like

I’ve now installed the latest OS manually - my FP2 is working again! No data lost.
At first I kept getting the warning “No Fairphone 2 found in fastboot mode”. Then I downloaded & extracted the ZIP archive again, and this time it went fine.
See https://support.fairphone.com/hc/en-us/articles/207914363
In the mean time I’ve learned about recovery etc, and I’ll make sure to make backups …


Interesting, so you’re saying you were getting “No Fairphone 2 found in fastboot mode”. And the only thing you did different was to redownload the ZIP file? There might be hope for me!

Can I ask which update worked for you? Was it the most recent one?

Yes, last update, OS 19.08.1, as provided on the support page on manual installation - see link in my message (same as the one posted earlier by Ingo and AnotherElk).
The instructions actually cover the warning "No Fairphone 2 found in fastboot mode”.
Good luck!

1 Like

It doesn’t work on my phone at all, tried the manual installation multiple times and also tried downloading the ZIP again. No result. Screen is black with text and the script keeps asking me if I want to look for the phone again.
Anyone who experienced this and were able to fix it?

Can you upload a screenshot here?

I am having precisely the same problem:

  • Reboot failed after the auto-update last night…
  • Followed the instructions on manual installation - repeated several times; got my phone into Fast Reboot mode (flashing blue light; usb connection to my Win10 laptop; heard the Windows accept sound jingle when I plugged in the USB, &etc.)

After running “flash-for-windows” multiple times, I still get:

** Fairphone OS 19.08.1 Manual Flashing Script **
Validating files…
All files are valid, let’s go!

WARNING: No device found in fastboot mode.
WARNING: Make sure that a Fairphone 2 is connected.
WARNING: To check for devices, type ‘bin-msys\fastboot.exe devices’.

Do you want to look for a device again? [(Y)es/(n)o]:

FP2 screen remains black with the “Fairphone” and “Powered by android text.”

My Win10 Control Panel shows a generic Android device is connected, but the status is “Needs driver” and there’s no option to update/install new driver.

I’ve tried all of the USB ports on my laptop; I’ve tried disconnecting, restarting and painfully following again each and every step in the process (2 thru 5); I’ve re-downloaded the binary twice (FP2 - Binary images of Fairphone OS 19.08.1 (~777MB) md5sum: c764109d20d0aae1019b513505dff76f).

But I’m stumped!

Suggestions, inspiration, ideas on this problem are welcome. Suggestions on where to find a good IPA anywhere in central Leiden also welcome… :wink:

HA! SOLVED!!! I went to my wife’s laptop (Win7; our home machine…) and tried it there - worked perfectly the first time! I guess my Win10 laptop (issued by my employer) had some sort of weird coroprate policies in place that blocked or interfered with the update script finding my FP2 via USB.

So, it ran exactly as described in the main article; the only thing I would add is that, at the end, when the Win script finishes and you see this:

Flashing successful!
Your Fairphone 2 will now run Fairphone OS 19.08.1.

Press Enter to reboot the device and complete the installation
Press any key to continue . . .

Go ahead and hit ‘Enter’ but then give it a good long time to reboot and restart - I waited ca. 20 mins during which I saw only the normal start-up screen (with the blue dots flashing underneath the Fairphone text). Then I sort of got bored, assumed it had hung up and then removed the battery to do a full restart - it then restarted in just a couple minutes just like normal.

The looming ‘Monday-morning-with-no-phone’ panic attack is hearby cancelled.

Cheers to all!

PS: Still need IPA recommendations… :wink:


Pronck, a brewery here in Leiden, makes a pretty respectable IPA - and that’s coming from someone who isn’t really into IPAs. I think they serve it at nearly every bar in the old city centre. Jopen IPA, brewed in Haarlem, is also quite good.

Also good job on fixing the problem, and on posting about it so other people with the same problem can follow your lead!

1 Like