English

FP2 does not list in 'adb devices' from my Linux workstation

Greetings All,

This is my first post, which covers a topic which seems to be recurring. I have tried everything to connect to my new FP2 via the adb, but it will simply not connect. ‘adb devices’ seems to be the best litmus test for functionality (why adb shell/push/pull/etc. is not working)

> adb version
Android Debug Bridge version 1.0.32

> adb devices
List of devices attached 
  • I have a working, freshly-upgraded Android Platform SDK (with adb) which can connect to my Samsung S3

    adb devices
    List of devices attached
    4df1ba7399999f6e device

  • I have enabled “USB Debugging” in Developer Options and disabled all other USB-based services that I can find (according to other posts)

  • I have read every post on performing this initial connection that I can find; the most-relevant one is closed for new posts

  • I can see my device appear in my ‘dmesg’ log when I plug it in, however, with a suspiciously-short serial number (it is 8 characters, rather than 16 as in the fully-functional phone)

    usb 1-2: new high-speed USB device number 18 using xhci_hcd
    usb 1-2: New USB device found, idVendor=2ae5, idProduct=9039
    usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-2: Product: Android
    usb 1-2: Manufacturer: Android
    usb 1-2: SerialNumber: ed3abcde

  • I’ve tried both as root and as a user who is a member of the plugdev group

  • I’ve added the device entry in the udev rules, which seems to be unnecessary for my other phone to connect.

    cat /etc/udev/rules.d/51-android.rules

    New USB device found, idVendor=2ae5, idProduct=9039

    SUBSYSTEM==“usb”, ATTR{idVendor}==“2ae5”, MODE=“0666”, GROUP=“plugdev”

  • The FP2 is recently-upgraded and lists the following version information:

    Android security patch level: October 5, 2016
    Baseband version: 4275.1-FP2-0-06
    Build number: r4275.1_FP2_gms66_1.8.1

  • fastboot can list the device, though it hangs in the waiting for device

    fastboot devices
    ed399999 fastboot

    fastboot reboot
    < waiting for device >

nothing happens no matter how long I wait

  • my problem sounded like the “USB3 bug” described here, but the solution of adding a USB2 hub in between did not change the situation

What could be going wrong here?!? It’s like this phone simply will not start the daemon nor allow a fastboot command to complete.

Any ideas? Thanks.

Maybe it sounds stupid, but I guess you tried all connection modes (swipe down from top after connecting)?
Sometimes switching between the modes can initialize the device.

Another common problem is that the USB cable is not transmitting data. Try different cables, maybe they work.

Good luck!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.