English

FP2 - "do not disturb" auto-activates!

Tags: #<Tag:0x00007f05e6f7c658>

Hi

I am new in this forum and I am quite happily using my fp2 in a daily basis for 2,5y now.
I got used to most of the flaws and am a strong advocat of the FP Idea, but faced recently a serious problem which I am unable to resolve:

“do not disturb”-mode activates itself without user-action (p.e. while carrying it in my pocket) and this make me miss important phone calls!

This is the one and only problem which seriously make me reconsider my choice - never had similar probs with my Sony XC 1 compact.

I am running Fairphone open 19.11.2 .

What I tried so far:

  • recalibrating proximity sensor
  • checking the sensor with an app on F-droid
  • discussing the issue with the support-Team -> most likely no hardware problem
  • deleting all (switched off) stock rules for d-n-d
  • System-UI-tuner: option of activating d-n-d by volume keys switched OFF

As I NEVER use this feature, I would be even happy for a hack which deactivates this mode completely!

Any help would be very much appreciated!

I’ve never heard before of this feature activating itself automatically. So I assume it’s a very special case.
I can imagine two reasons

  1. It’s accidentally activated by (involuntarily) pressing the according button in the quick setting menu
  2. An app activating it

For case 1: that’s not really probable but I’d recommend you move the d-n-d icon away from that menu by pulling down from the top twice, selecting the pen icon and moving the icon to the unused ones
For case 2: you might check if it’s activated by an installed app by starting your phone in #dic:safemode . But as I understand that the problem only happens sporadically I assume it will be hard to trace that down…
If you have a working backup you might also try a factory reset and check if it happens after that with only the most needed apps installed…

1 Like

Hi Volker, thanks for your advice. I allready elleminated the d n d icon from the “drawer” … de will see. If the issue repeats, I will try your second Option. A lot oft people had this issue in this forum but right, never had it withothetr phones. For my professional usage, it is crucial to becabke to be called 24/7/365 … at least ring tone shouldNEVER be muted! Maybe there is a workaround?

1 Like

Perhaps you can try to go in settings and allow calls and messages to still ring when DND is activated (and all the rest as well). I don’t know if you already did it or not, and I’m not sure there is this option on FPOOS (I’m on Lineage), but it’s worth a try.
Does it switch on randomly or could you observe a pattern? If there is a pattern, maybe somehow something programmed DND to switch on at certain times, but as I understand it you already deactivated these rules.

1 Like

Did you check >>Settings -> Device: Sounds -> Do not disturb -> Automatic rules<< if there are really no entries existing?

2 Likes

Hi Amber,

Yes, I did. At least, i never missed calls again up to now. But I just got a call, were D N D was autoactivated - I had to deactivate it manually (I activated in the settings, that even with D N D active everything possible (CALLS!) is nevertheless let through :wink: Weird … but I could live with this strange behavior, IF FP2 NEVER again mutes the ringtone itsself!

Thanks for all your help!

2 Likes

I also have a FP2 and multiple situations recently were DND was mysteriously on even though I had no memory of having activated it. Annoyingly I also missed important calls. I thought maybe it’s just me and my finger slipped but after seeing this discussion I’m not so sure. I’m using the non-Google version of Android provided by FF, up-to-date version.

Hi Titus

Titus von der Malsburg via Fairphone Community Forum:

[tmalsburg] tmalsburg https://forum.fairphone.com/u/tmalsburg
June 30

I also have a FP2 and multiple situations recently were DND was
mysteriously on even though I had no memory of having activated it.
Annoyingly I also missed important calls. I thought maybe it’s just me
and my finger slipped but after seeing this discussion I’m not so sure.
I’m using the non-Google version of Android provided by FF, up-to-date
version.
I am also using FP-Open - maybe its a bug there?

Hi,

DND is always active during calls to avoid your phone buzzing or playing a notification sound when holding it to your ear. If it activates at any other time, check your volume buttons. Your volume down button may be stuck or pressed too easily.

You could try taking the buttons out of your phone’s back cover to see whether that avoids it. Although you’d be unable to set the volume then - but nevertheless good as a test!