English

FP2 compatible with Flir One?

Hi.
My name is Morgan Leijström and i Live in Kivik, Sweden.
I am a self employed techician/inventor with interests in environment and society, so i stear my projects and choose tools in that direction. Fairphone seem to fit this direction perfectly :slight_smile:

The phones i normally have are second or third hand, as i only use simple apps, camera, SMS.
-And sometimes i talk to someone using this handheld computer+radio-modem thingy that also can emulate a phone…
(i will never call such a device “smart” and it is not a actually phone)

But… soon i need more computing “OOMPH” in such a handheld computer.

Fairphone 2 seem to be a strong enough computer, and run Andrioid5 which also seem to be needed when reading how the thermal imaging camera FLIR ONE (version 2) performs on similar devices.

I guess it can run virtually every other android app and hardware gadget that similar devices can?

Here is the device i want to run.

FLIR ONE Thermal camera for Android hands-on - SlashGear (forum said max 2 links for new user…)
Manufacturer: http://www.flir.eu/flirone/content/?id=69420

I need thermal imaging in a few projects, ant this is the cheapest that will perform good enough.

  • And it (hopefully) give me a reason for my company to buy a Freephone2 for me :slight_smile:
    Will it work?
2 Likes

Hi Morgan! I changed the topic title, to better reflect the topic’s content. If you’d like to introduce yourself, we would be glad to see a post of yours here. :slight_smile:

There are only few devices listed under the section “Compatibility” on the site which you linked above. And even among them only a few seem to support all features properly.

I would not rely on the guess that it hopefully works with any Android handset. Better ask Flir what a phone needs to be capable of in order to support Flir one. Once you have that information you can compare it to specs of Fairphone 2.

Edit: Under “Specifications” they list the following:

Device compatibility: Android products containing a micro-USB

Fairphone 2 certainly meets these criteria. Maybe the compatibility table on the same site is only to examplify how Flir One works with the most prominent phones.

The HTC ONE M8 is tagged with “Tested Successfully”. According to gsmarena.com it has exactly the same setup as the Fairphone 2:

Chipset: Qualcomm MSM8974AB Snapdragon 801
CPU: Quad-core 2.3 GHz (US/EMEA)/ 2.5 GHz (Asia, China) Krait 400
GPU: Adreno 330

I would be very surprised, if it didn’t work. (My opinion, no guarantee for anything!)

VERY interesting gadget… Thank you for the hint!!

Thanks Stefan. I now introduced me there.

Thank you for the replies, all.

I too find no reason FP2 and FLIR One (v2) should not work together.
I looks like the cam performs better with later OS version and faster CPU/memory, and FP2 got it.
It of course depends also on driver compatibility for fast USB and for video display, but that is hardly special for this app, so I guess that if it will not work at release there will be updates fixing it.

I have also checked that the USB connector is turned correctly for the camera to point forward.
(If i should connect it to my (also otherwise incompatible) HTC Desire HD, it would point to the user instead…

Anyhow, partly working with electronic cirquitboard prototyping i could maybe turned it around if it was needed :wink:

Now I go pre-order my FP2 :slight_smile:

1 Like

Hello,

I did a little test run using a FP2 P2 sample device(not the final hardware) and was able to connect my HackRF one on the FP2 at 20 MB/s (the maximum rating the HackRF allows). Flir One should not be a problem (The buspower is also good). While looking a the Flir one I wondered if the Flit’s micro usb connector can be turned around. FP2 has the micro usb connector the connected in such a way that the usb logo on the plug will be on the same side as the screen, e.g. the right way, as opposed to the current FP1 or for example a Nexus 5 device.

4 Likes

Thanks for the info on speed and power.
The Flir one have an internal batteri, but good to know FP2 can support devices that need a bit of power.

I have a radio amateur friend that probably would like that HackRF One - maybe even myself at work as a equipment for pre EMC lab testing. Hmmm…

Looking at the pictures of the Flir one it does not look like the connector is rotateable.
Maybe there finally is a standard for the connector location and direction?
about time if so…
An alternative would be an M-F micro usb extension cable.

I look forward to when there are USB-C ports on most everything. That standard support lots of different and high speed concurrent data and much power both directions. Finally the U in USB will be valid :wink:

1 Like

Any news?

Has someone already tested the flir one or the seek thermal with the FP2?

Got my FP2 yesterday, very satisfied, it is working nice :slight_smile:
Installed FlirOne app, said it worked but image was all black.
Rebooted = works pretty much OK but realtime video stutters.
Today: again black. Rebooted = runs one secons then picture freeze, new take=black.

I can shut down app normally. That it is better than on my fatherś samsung running Android 4, where the app works first time, but later hangs the whole phone.

To me it looks like the app or possibly the FlirOne camera is severely broken or far too generally incompatible for my taste. This is the fifth phone i try it on, and best so far… I will contact Flir company about it.

Is it possible to get some debug info of some kind from running the app?
I am a power user on Linux (Mageia) but have never dived into Android.
Maybe it need some rights or buffers adjusted, or some special version of some… USB port driver of some kind, or its settings… - but strange it worked after first reboot…?!

Hello Morgano,

Best is to enable adb debugging in the developer mode and grab the logcat and dmesg output (after you plugged and unplugged the device)
e.g. (from linux run)

  • adb shell dmesg > dmesg.out.txt
  • adb logcat -d > logcat.out.txt

and look at the content.(don;t post it for privacy reasons)

Thanks keesj
I meant i am a power user on Linux when run on PC.
On a phone i have never been to command line.

Any hint on where to learn the basics of Android 5 like how to get to developer mode, tools, rights, file structure… ? I guess i can somehow shell into it using the usb port?

  • Not meaning you to teach me, just advice where to look to learn.

You will need to install adb (android debug bridge) which basically allows you terminal access from your computer to your phone.

Not sure how it works on Mageia, but in Debian based distros you need to install the package android-tools-adb (maybe there is a similar package available for Mageia; edit: maybe this helps; according to that link you might need to install the SDK package).

Then you need to turn on developer mode on the phone: go to settings --> (scroll down) about the phone --> click about 10 times on Build-number and developer options become enabled. Then again in settings you will find developer options just above “about the phone”, open it, activate it, also activate usb-debugging.

Connect your phone with your computer through a data cable, uncheck all usb connection options on the phone (like mtp, sd-card, or charging etc) from the Android drop-down/notification menu, and you should be able to communicate via the adb from your computer to your phone. then you can run things like logcat etc.

This sounds similar to some issue I had with VLC. Videos stay black until I tick “deactivate HW-overlays” in Developer Options. Could you try if this makes any difference?

1 Like

§ aktivated developer mode and deactivated HW-overlays: no change, even after reboot: runs a few seconds, then picture freeze. Thanks for the tip though.

§ I have a ticket at flir.com, i will report any progress both ways. I also suggested they send FP2 developers a sample :slight_smile:

Will try adb later, now i must attend other tasks.

OK... what should i look for?

In logcat i see a lot of lines with “Failed to ensure directory” like:
W/ContextImpl( 6847): Failed to ensure directory: /storage/sdcard1/Android/data/com.flir.flirone/cache

My /storage/sdcard1 is empty. (note the “1” at the end)
I guess an added SDcard is supposed to show up there. I do not have any.
(I have a very old 1GB but this phone seem to refuse it)

I guess it is just testing, and not really needing sdcard1. When FlirOne sometimes works it managed to save still images in /sdcard/DCIM/FLIROne

Anyhow, i tried an elder version of the flir one app (1.2.1 instead of current 1.4.1) which i got from flir one support by link https://www.dropbox.com/s/t58kog6ejaqru7j/FLIROne_1_2_1_41_mobile-release.apk?oref=e … it possibly worked a few seconds more before picture froze. I could still “record video” and the seconds counter counted, despite it did not display image and video file is not playable…

uninstalled old again, rebooted, installed current 1.4.1 version, rebooted, test, app froze:

In dmesg i see
<7>[ 567.475814] usb 1-1: usbfs: USBDEVFS_CONTROL failed cmd om.flir.flirone rqt 1 rq 11 len 0 ret -71

<7>[ 580.596055] usb 1-1: usbfs: USBDEVFS_CONTROL failed cmd om.flir.flirone rqt 1 rq 11 len 0 ret -110

<7>[ 622.249004] om.flir.flirone: unhandled page fault (11) at 0x00000008, code 0x005
<1>[ 622.249047] pgd = ebc28000
<1>[ 622.250873] [00000008] *pgd=00000000
<6>[ 622.254297]
<6>[ 622.254329] Pid: 6889, comm: om.flir.flirone
<6>[ 622.254370] CPU: 3 Tainted: G O (3.4.0-gcd7fdcf #1)
<6>[ 622.254505] PC is at 0xa3f7e0c8
<6>[ 622.254533] LR is at 0xa3f7ead4
<6>[ 622.254565] pc : [] lr : [] psr: 60070010
<6>[ 622.254579] sp : 9fc01b30 ip : 00000001 fp : a00db4d8
<6>[ 622.254838] r10: a00f626c r9 : a06caa00 r8 : a06da64c
<6>[ 622.254875] r7 : 00000055 r6 : 00000055 r5 : 000000c7 r4 : a4490e78
<6>[ 622.255288] r3 : 00000000 r2 : 000000c7 r1 : 00000055 r0 : 00000000
<6>[ 622.255326] Flags: nZCv IRQs on FIQs on Mode USER_32 ISA ARM Segment user
<6>[ 622.255654] Control: 10c5787d Table: 2bc2806a DAC: 00000015
<6>[ 622.255761] [] (unwind_backtrace+0x0/0x11c) from [] (__do_user_fault+0xfc/0x148)
<6>[ 622.256136] [] (__do_user_fault+0xfc/0x148) from [] (do_page_fault+0x34c/0x3e0)
<6>[ 622.256476] [] (do_page_fault+0x34c/0x3e0) from [] (do_DataAbort+0x134/0x240)
<6>[ 622.256545] [] (do_DataAbort+0x134/0x240) from [] (__dabt_usr+0x34/0x40)
<6>[ 622.256582] Exception stack(0xd321ffb0 to 0xd321fff8)

Flir support recommend FP2 developer to join at http://developer.flir.com/

I am having my FlirOne camera exchanged, just in case it is something wrong in it.
I will probably have the replacement within two weeks, I will try it then and report.
I think the app should not page fault anyway, but that might be a latent bug trigged by camera fault…?

To test your thermal camera for functionality, you can plug it to your PC (you´ll need an mirco usb-usb adapter).
I just got my seek thermal but not yet my fairphone (Ordernumber 29k something, ordered october, with only ~18k delivered Fairphones I however doubt I will get it this week …) but some python code later (http://www.eevblog.com/forum/thermal-imaging/yet-another-cheap-thermal-imager-incoming/msg571129/#msg571129 helped a lot) … i now can use my laptop (ubuntu) with the thermal camera ^^ I am pretty sure, there are also solutions for FLIR One.

Now however, me and my nephew …


… just NEED to have this functionality also on my FP^^ (And of course I need my FP … but … well)

My flir 1 has been on back order for many weeks. The suppliers just can’t get them.

From the photos, the USB (which can’t be rotated) is correct for the fp2 … But back to front on a nexus 7 … Which flir says is fully tested and supported … Hoping to use the flir on both.

I’ll report when … IF EVER … my flir one arrives.