FP2 Cannot Connect To PC via USB cables

Hello: I want to add music to my phone but I cannot. The phone and computers do nothing when plugged together except that the phone says it is “Charging” (but does not actually charge unless I turn the phone off). Here is what I have tried:

  1. 3 Different USB cables including a brand new high quality Duracell cable.
  2. 2 PCs
  3. Windows 7 and Windows 10 (Neither recognized it)
  4. Emptying App Data
  5. Turning the phone on and off while plugged in

I would prefer to not factory reset the phone as I have sentimental text messages on it that I have no way to export.

I’ve been searching all over for a way to fix this.

Thanks for your help.


Until someone more knowledgeable chimes in …

I think some people were able to fix this by enabling USB debugging in “Developer Options” in Settings. Other than that, I would have suggested to clear the cache of Media Storage, but I guess you have already done that (point 4).

1 Like

… and when connected, swiping down from the top and tapping the “Charging” notification where you can change the connection mode from “Charging” to “Transfer files” (or the like, German locale here)?

In case of SMS, MyPhoneExplorer can do that for you.


Hi! Thank you for answering. How do I navigate to USB debugging on open is?

I don’t get anything when I swipe down while plugged in

I also do not want to connect to an app store service because I feel they take too much private data.

hi jonny,
i think you need to enable developers options… go to settings/about phone/ tap on build number 7 times.
back to settings, then developers options, scroll down to “networking”, tap “select usb configuration”, tap “MTP (media transfer protocol)”… now you should be able to see your FP2 in windows explorer and transfer data to your phone and vice versa.



Yee-Haw! That worked!

One thing I would add is that after all of those steps, when it’s plugged in it still says “Charging slowly” but then I swipe down and it gives me the option to choose MTP.

Sweet! Thanks!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.