English

FP2 Bricked - Recovery Help

From where is the official primary ROM supposed to be downloaded? I managed to save one of the Updater ZIPs on my laptop before flashing my own build, but it’d be great to know.

BTW, in my own-built FairphoneOS-OS, the Updater keep saying something like “Unable to download config file” (in Spanish) and doesn’t show me the “Advanced options” to reinstall any official ROM. Do you know if this is something exclusive from my build or a general issue?

EDIT: Quoting @Flogo for additional info to new readers

I can confirm this behaviour, I get the same message (in German though :wink: )

1 Like

I might have an issue now as well after I experienced difficulties getting the SD card to work properly. Now I would like to start from scratch and reinstall factory Android FP (or actually any other image you can recommend).

My phone is not bricked (yet) which is the reason that I’m asking here before doing anything stupid.
What doesn’t work:

  • download FP2-GMS36 1.1.7 via updater (Error downloading FP2-gms36 FP)
  • writing to any storage with Amaze (no permissions for sdcard0 or sdcard1)

I’d like to fix these issues obviously, maybe they are connected, who knows.

I get access with adb and can write onto the sdcards with that. What also works is mounting the sdcard1 via USB.

What do you recommend? Install FP2-GSM or directly installing a different image?

Thanks for the help!

I don’t think there are any official other images out there yet. All what is “official” out there is the stock google rom.

Updater-file:
http://storage.googleapis.com/fairphone-updates/FP2-gms36-1.1.7-ota.zip

Images-file:
http://storage.googleapis.com/fairphone-updates/FP2-gms36-1.1.7-img.zip

I would use the 2nd one with the images and fastboot flash. And I would replace the recovery while doing so. You don’t need Amaze if you have adb or fastboot or a working recovery.

I haven’t fully understood your SD card issue yet, so I can’t really help. Just providing links to files. I always thought SD card handling would get better in Android 5 not worse.

1 Like

Thanks a lot for that information.
What is the difference between the two files?
What do you recommend replacing the recovery with? Is there a better one? Should I flash first and then change recovery or the other way round?
Do I flash those files simply by putting them onto the SD card, restarting the phone to bootloader and flashing them there? Or should I do it from recovery?
I have exactly the same problem as @barney now

There is a twrp port here in the forum. But I would try to learn all this step by step. How to do a backup, how to reinstall stuff … so that you have all this when you need it. The best is you just try it and write a howto while doing so :slightly_smiling:

I don’t own a FP2 so I don’t want to give you wrong information. But if you read the wiki about building your own non-google images, you can also see how these images get flashed. It’s the same with other images.

Normally you put your phone into the bootloader/fastboot mode and unzip the images (FP2-gms36-1.1.7-img.zip, the twrp image) on your computer and flash your phone from there.

I wonder why I am so afraid of flashing again. It’s just been a while since I flashed by old phone.
Managed to install the original ROM with:

  • reboot to recovery
  • reboot to bootloader
  • download FP2-gms36-1.1.7-img.zip
  • unzip FP2*img.zip
  • fastboot flash boot boot.img
  • fastboot flash system system.img
  • … do for all 5 images
  • fastboot reboot

Good, now you can try to replace your recovery with twrp! But don’t blame me if something goes wrong :slight_smile:

Not sure if I should…

I’d start with fastboot flash -w system system.img

I got everything flashed. However I am wondering why I can’t get permission to do shell su

You are using the stock rom. They do not provide rootable/google free images (yet). If you want to become root on the stock images, you have to follow the “Root with Superuser” part in that is also linked in the howto.

I didn’t have the superuser app installed yet

It’s not about the app. I can only recommend to read the full article if you want to become root on the stock FP2.

I know, I know, I know. But interestingly, a rooted phone will not grant root access without superuser.

If you uninstall Superuser and try to shell: su you get permission denied. With superuser, your phone will say “Superuser: shell access granted” or something.

So I rooted but didn’t install the app yet and still tried to change permissions. That didn’t work.

My guess is that you are using a terminal emulator on the phone. The real Android shell is accesed by executing adb shell from a computer with the device connected. I think that’s the shell where you can su without Superuser installed, but I’ve never tried it without a “superuser manager” app installed, being honest.

(Sorry if I’m wrong, it’s just a guess. Let me know, anyway)

No, not doing that either. Just try it out. Uninstall superuser, connect phone to the PC and try to adb shell and su. You’ll get permission denied

I’ve not rooted my FP2-OSOS yet (I’ve not needed it yet), and my former Nexus 4 has CyanogenMod, so can’t really uninstall Superuser. Maybe someone can try it out and see if that’s the correct behaviour.

Well, as typing su pops up a permission window I can imagine this. But I only know SuperSU… Guess there is a critical component missing, then…

1 Like

Superuser provides it’s own special “su” that can be controlled in various ways, the app somehow controls a “white list” what software can become root and so on.

SuperSU works similar and is more or less the same.

If you have issues with superuser, just install a working recovery and install SuperSU.zip through the zip file instead.

Good luck!