FP2 Bricked - Recovery Help

Nope, sideloading the OTA-zip doesn’t work for me. I also tried different USB-cables. It might fail since the recovery I’m using is self-compiled using the instructions on http://code.fairphone.com but that’d be a strange reason.
I’ll tell you if it worked usind the sdcard as soon as copying finished.

If you’re using a self compiled recovery you might as well disable the zip file verification. I think this is only a hassle and does not serve any real purpose

“Applying update via sdcard” also failed for me with both OTA zips (1.1.6 and 1.1.7) though the MD5s of the files match what’s in the updater.xml. Sadly I can no longer try using the original recovery system since I don’t have the .img (No one except Fairphone has, I assume).
@lklaus: Sure I could disable that. I’m just wondering why it failes on the official updates released by Fairphone :smirk:

interesting… I uploaded it via adb sideload and it worked on the very first try…
why would a custom recovery impact the installation of a standard rom? Doesn’t make sense to me…

Does not make sense, I’m simply not sure in the recovery are all keys used…

Freibadschwimmer suggested to me to ask you for help here
I made some mistakes concerning getting write access to my sdcard
Now my phone is dead and I tried to recover it but I couldn’ succeed.
Which mistake have I done?
Could you help me to restore my phone?

I am a beginner!
Though I first stored the FP2-gms36-1.1.7-ota.zip on my sdcard.
Then I booted into recovery mode (at least I think so) and chose “install update from sdcard” and pointed to the ota.zip .
The phone installed it but after the reboot I got error messages like “google services are terminated” as well as Hangouts and more about google services.
I can’t finish the setup wizard because of the failure messages (google services are
terminated) and the wizard itself gets terminated. These messages began before flashing after a mistake in editing the platform.xml because the storage and the external sdcard weren’t recognized any more.
Did I make any mistake concerning the flashing?
I guess that the storage partition has to be recovered or created new?
I want the phone to be as it was delivered. What else do I have todo?
Could anybody help me because I am a bit despaired about my newe phone and begin to get hopeless.
Do I have to send my phone back to FP?

Maybe try to flash ota.zip in fastboot, as you can add -w, which does some wiping too

Hi Iklaus,
thanks very much for your advice!

I tried to reach my phone with minimal adb and fastboot yesterday night and a few minutes ago and it’s not listed.

Would the install work though?
How should be the syntax? adb…?

If you are in fastboot mode, you have to use the command fastboot, not adb.
fastboot devices
fastboot flash -w ota.zip

1 Like

Josuttis wrote some very detailed instructions about adb and windows. Have a look at them: https://forum.fairphone.com/t/adb-on-the-fairphone-2-windows-driver/11529/15?u=irina_spitznagel

Hi Barney,
did the flashing via fastboot with the -w option do anything different?
In my case, flashing the ota image via adb worked fine. My system was running nicely again afterwards. Apparently you also managed to flash the new system but something different must be changed. Can you install any apps at all? I would be interested, in seeing your partitioning of the internal memory. I’m not a specialist on this, but I have an app called flashfire which lets me see the partition table and make backups of the individual partitions. Maybe you could download it and check what your partition table look like? Download is here: http://flashfireapk.com/FlashFire-Download.html
I’m attaching my FP2 partition table:

I can make individual backups of each, so if we can identify which one has a problem i might just send you a backup that you can flash back to your phone…

Thanks very much to all of you helpful posters!
I can’t access the devices properties since it’s blocked by the welcome-wizard which I can’t accomplish because of the error messages and it terninates automatically and starts again. So I can’t enable USB-debugging.
In recovery mode I chose “reboot to bootloader” (or something like that) and the phone gets accessible for fastboot commands but not for adb.
I tried the fastboot flash command.
But the system say either “cannot determine image filename for ota.zip”
(which I renamed to ota.zip and copied to the minimal adb-folder on PC and to c:\ ; I tried with and without paths)
or it says
unknown partition FP2-gms36-1.1.7-ota.zip

And of course I can’t install any apps unfortunately

the fastboot command goes as follows:
update filename => reflash device from update.zip
flashall => flash boot, system, vendor and if found, recovery
flash partition [ filename ] => write a file to a flash partition

so it expects a partition name first when you use the flash command. rather try flashall or update and see if that works…

Thank you Moritz, Irina and IKlaus for your kind help and also Freibadschwimmer!

None of the fastboot commands could be executed. The only thing that at least BEGAN to do something was the partition command. But of course (:wink:) it failed.

I found again the recovery wiki for the FP1 and executed it as I did it before by installing the ota.zip from the sdcard in recovery mode.
The new thing to me was the advice to now execute the factory reset AFTER the reinstalling!!!
And that worked!:grinning:
After a despaired week I got a working phone again and of course I’ll root it now :grin:
Jesus bless you all!:innocent:


How is that done? Does one have to edit the source code before compiling?

Yes, yolu’ll have to do some patching. It’s written in the wiki post [HOWTO] ✏ Compiling Fairphone Open OS / Rooting
with a wonderfull work from vivia

I’m glad you got your phone to work again! :smile: And to get general writing access on your SD card, try https://play.google.com/store/apps/details?id=nextapp.sdfix . It works well and there’s no risk to brick your phone again :wink: .

Thank you, Irina,
sorry, I don’t use google any more.
I tried again with adb push and pull. But again that didn’t work because of insufficient user rights as far as I understand it.
But I followed Freibadschwimmer’s hint (?, jedenfalls: seinen Tipp :slightly_smiling:), to edit the platform.xml with the Amaze-Editor. Worked phantastically without brick :grin::innocent:
Good night!


or you can take the easy route and just flash a finished twrp recovery from this threat :slight_smile:

1 Like