FP2 Bricked - How to revive if it via PC?


I’ve bricked my new Fairphone and now I can’t get any mode starting.

How it began:

  • wantet root access to get my old apps going with titanium backup
  • flashed a root image with fastboot: worked
  • updated FP2 OS - root access was gone
  • learned about FP2 OSOS with integrated root access: want FP2 OSOS
  • Same thing like here: Using updater didn’t work, used fastboot, no error messages, just bootloop afterwards.
  • flashed TWRP
  • installed the latest FP2 OSOS .zip with TWRP, one error message that I don’t remember, but the Phone worked.
  • now I loaded opengapps Pico for Android 5.1 and arm, formatted the phone, tried to install FP2OSOS .zip and after the opengapps in a queue, didn’t work, tried again - first the OS then the gapps. When installing the gapps there was one error message and after one second the phone went black and stayed like this until now. No reaction to button press, however long, or PC connection. One “good” thing: It got once recognized as “input device” on windows.

My (little) hope left: to flash a binary via PC - like in this tutorial for FP1. I just couldn’t find a OS version that has the file order that is needed for the SP Flash tool (for example a scatter.txt file).

If anybody has ideas on how to revive the phone or what could be the reason I’d be greatly thankful!

Why did you do that? :disappointed_relieved:
I think this is how you bricked it.

It may be possible to revive it by doing the steps described in “4. Flash the binary images from a computerhere.

1 Like

Does your phone light a led when you plug it to an AC adapter ? Can holding vol. up + power button for a while start your phone in recovery mode ? vol. down + power should also boot you up in bootloader mode.

Also given you managed to use fastboot, try using “fastboot devices” while your phone is plugged to the computer to see if the phone is recognized as in bootloader mode by your computer.

1 Like

So can you still access fastboot (Power + Vol. down, and then check with fastboot devices)?
If so, you should be able to install FP Open OS like described here:

That’s the problem - no access to any mode. Not even the loading battery screen is showing up. Isn’t there a way to copy the first bits of data from a computer onto the chips?

Update after a long mail conversation with the support: None of their ideas worked either. Nor did any of the tutorials for bricked qualcomm chips because even with Qualcomm drivers the phone got recognized as input device and not as a Qualcomm device under Windows. The device information in linux mentioned Qualcomm as the manufacturer but it was still a input device.
In the end I returned my phone and they sent me a new one. A big Thank You! to the support at this point. I’d still be interested of the original phone could be repaired. With the new phone everything worked as it should to install OpenGApps and Xposed. Here my short instruction:

  • update Fairphone OS
  • install FP Open OS using the zip (in my case it needed to be transfered via PC)
  • shutdown, boot into TWRP recovery which comes with the FP Open OS (Power, Vol Up)
  • Install OpenGApps (full Tutorial here)
  • and the XPosed Framework
  • restart, setup your phone and disable location service to use the Playstore
  • don’t format anything - retsifp was probably right.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.