English

FP2 Bricked(?) after marshmallow update

Hello everybody. I’m new to this forum, hope I don’t break any etiquette while here :slight_smile:

I am writing here today following the accidental release of Marshmallow. As an enthusiast Android user, I immediately did the upgrade. As multiple other people, I had a boot loop (described by some people , the phone constantly trying to “optimize app”. I had to do the factory reset (a lot of lost data, but that’s life… shame on me for not updating my backups). But still no luck.

From here I tried a lot of solutions and installation (all following the official guides from FP). Basically, I tried :

  • “Update” with the previous Fairphone OS 1.13.0, but as it was over a newer, not allowed to do so.
  • Install the 1.13.0 with a clean install. It almost worked, as I managed to have a running phone but very buggy : the notification center did not work, as well as the Home and ‘Previous app’ (is that the name?) buttons. Really not a fully working phone…

So finally I tried to install the Fairphone Open OS (latest again, 1.13.0). Here again it almost worked. I had a running android, everything seemed fine. But I installed the GAPPS , one essential (for me) app (Telegram Messenger), and there it was buggy. I barely managed to open the app and configure it (later attempts failed, app stops responding), and every once in a while the phone “freeze” (meaning it is still running, but power button does turn the screen on).

Additionally I tried :

  • With FPOS, to update to the same version with updater : 4 out of 5 attempts ended in the same “frozen phone” as described earlier. One completed, but did nothing useful (still no home button etc.)
  • With FPOOS, upgrade to FPOS using udpater. Update failed miserably multiple times.
  • With FPOOS, “upgrade” to same FPOOS version, successfully but with no effect on stability.
  • At some point (honestly I did so many things, I can’t remember what path led me to that), I had a running Marshmallow but also buggy.

So yeah, I’m kinda lost right now. Is my phone bricked ? Is there a way to install I haven’t tried yet, to do a complete clean install ? Shall I go to the vendor and try to have it changed (hate this consumerist solution) ?

I think I told you everything needed… If not, please tell me and I’ll provide you with as much info as I can.
Thanks in advance for you help ! (would have put more links to my researches, but I’m not allowed as a new user)

What does still no luck mean exactly? Were you still in the boot-loop`?

In the following text you describe different issues. Whether they are directly related or not is hard to say.

What OS are you on right now and what issues do you experience there?

Hi, thank for your answer.

Yep

In a way all of these are related (I think), as from the marshmallow update 2 days ago, I still haven’t been able to recover a fully functioning phone.

Now I’m on FPOOS 1.13.0. The phone sometimes freezes (as described earlier), the one app I installed via Play Store does not correctly behave (I can’t launch it, it hangs). Furthermore the SD card does not seem to be recognized (but honestly it’s a minor problem considering the first 2).

Have you performed a wipe in TWRP yet, so with FPOOS? That should usually get rid of all software issues.
If that doesn’t help you can try this (there may be a better way to do what I’m about to describe):

  • Perform an advanced wipe in TWRP and include “Internal Storage” (so basically everything).
  • Reinstall TWRP via fastboot
  • Reinstall FPOOS via TWRP

[solved] Ok, so your answer kind of helped me.
Here is what I did : with the “not-totally-working-FPOOS”, I went to the TWRP, tried to install the FPOS. Denied, as older build. So did again a complete factory reset (probably the 5th time in 2 days :joy:) with wipe of everything (cache, data, SD,…). I booted, got “stuck” on the FP logo as there were no OS. Then I used fastboot to do a new install of FPOS aaaaaand… it works. I already tried the fresh install earlier, somehow these steps worked and not the previous ones. Hope it’s stable (it looks for now, installed a few apps and works like a charm).

Thank you for your help, and have a nice day !

1 Like