FP1U- still on Hazelnut 1.7. Why do I contionously get "no updates available"? When buy new battery?

Hi! Searched the support pages and the forum to see if I can get why FP1U to work better. Found some advice in a few smaller matters. But when it comes to updating I couldn’t find exactly what I was looking for. I also need your advice in two other areas. Thus, following questions:

  1. The battery is running very low, very quickly, after 1,5 years using. It can go down completely in just a few hours, without doing any energy consuming stuff. Tried the suggestions in battery saving from the support pages. Does not seem to make a big difference. Should I just buy a new battery?

  2. My phone run on Hazelnut 1.7, (and has done so for a long time.) The updater icon tells me there are “No updates available”. I don’t have Wifi at home or work so I don’t use WiFi for longer periods of time than a couple of hours, but even then, I haven’t been able to update to Kola Nut. I get other updating “offers”, from apps etc but not any"Updating offers". What do you suggest?

Oh,and I have only (older)Mac computers around me, which is complicating things manually, since they don’t even “find” the Fairphone if I plug it in…

Not very technical I’m afraid. Getting really frustrated with it all. Hope someone will be able to answer this in a simple way. Big thanks in advance!

Ad. 1: Please check the #batteryguide. Especially make sure the battery is not bloated and if it isn’t try a battery reset (both described in the guide).

Ad 2: Try a manual update. You’ll need to connect to your mac for this and to do so make sure you have “Filetransfer for Android” installed, a USB-data cable at hand and your phone’s connection mode set to MTP. You can chose this at the popup that usually appears if you connect to the computer. If the popup doesn’t appear go to Settings > Storage and hit the menu button.

Thanks for prompt answering @paulakreuzer, I’ll try the manual update then.

I have already tried the battery reset and the battery not bloated. So I guess I need to order a new one …

Nighty night :slight_smile:

Hi again,
I’ve come a bit further in updating, but not the whole way: I’ve put in a sd card, downloaded the zipfile to the computer, put it in the download file n the internal memory, and been going over the steps in how to install Kola Nut manually down to tutorial step (9-)10. (I get the Recovery mode resting robot straight away and not a menu when I press the powerbutton and volume up. It says: No command. )
I can get to the menu and choose the “Apply uppdate from sdcard” but there is no download nor zipfile there to choose. Just “…/”
"…/LOST.DIR" and “backup”.
I’ve cleared data in the Fairphone updater app and rebooted several times, and i took away the google apps that was in the downloadfile.
Please, What now?

Use Amaze to move the zip to a location that you can see in recovery mode.

Thanks Paul.
Is there Amaze for Mac? Find it only for PC. Sorry, I’m …a learner in
this area :stuck_out_tongue:

Oops sorry, Amaze is the preinstalled File Explorer on the FP2. On the FP1 the equivalent is called File Manager or something like that.

1 Like

It’s an app for your phone. Download it from F-Droid:


F-Droid is an alternative app store (similar to Google Play) and offers only free and open source software.

Thanks, both of you. Yup File Manager is more recognizable for me as an F1U
user :wink: Good tip with F-droid. :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.