FP1U Data partition read-only, no Fastboot or Adb procedure work

I have a FP1U with Kola Nut 1.8.5 (not yet updated). Last week had a problem.
After several nights spent to understand what happened to my FP I discovered that the data partition becomes read-only in some minutes after the boot. When it starts to work I have some seconds to “Enable Debug” and to start an adb shell because then it becomes unusable (all the Apps crashes and GApps stress the system).

I tried several solution (manually install the new OS, install CWM, restore softbricked and totally bricked) but nothing change. Everytime my FP restart at the same status.

Every fastboot procedures (to format, for example) return to me an error and then it freezes completely.
I can only flash the recovery but it returns the same error and then, after rebooting, nothing change.

➜  Fairphone# fastboot flash recovery cwm-fp1-kk.0.1.img 
**ERROR: could not clear input pipe; result e000404f, ignoring...**
**ERROR: could not clear output pipe; result e000404f, ignoring....**
sending 'recovery' (5788 KB)...
OKAY [  0.343s]
writing 'recovery'...
FAILED (remote: 
partition 'recovery' not support flash)
finished. total time: 0.362s

The last test I did was by SP Flash Tool: the EMMC Memory Test.
I got a very strange error about the ROM:

with the SP version 5.1352:

with the SP version 5.1532:

Now I’m quite sure that the problem comes from the EMMC memory support.
What do you think about it?
Can I send it to repair? (I bought it on May 2014).

1 Like

What tests have you been running? Are there more reports you could run/post?

Looks like the eMMC could be broken. But I don’t trust the SP software enough to run it on my computer to test how it looks on my phone. :frowning:

BTW: Do you have a working MT6589 scatter file?

I did that tests with SP Flash Tool, the “EMMC Memory Test” in Advanced mode".
Not more reports, that windows stop the process and don’t give me anything more. Is there some logs more verbose?

Yes, I have a MT6589 scatter file from the binaries downloaded from this site.

Sorry, I never used the software before, but SP seems to have some tests available. Have you tried the Unix version to exclude driver issues on Windows? I don’t trust this software, make sure you use the ‘right’ sources (if they exist …) for getting it. Maybe there are some hidden fastboot tricks that can do the same thing? I don’t know much about this or the oem options.

Maybe it’s a good idea to write the support at this point and to ask about your warranty and if they have any more clues :wink:

This may be a bit random, but does the data partition also become read only if you remove any SIM cards that are normally in the phone along with the SD card (if present)?

1 Like

@fp1_wo_sw_updates thanks, I wrote to the support. I hope they will fix it under warranty.
About the SP tests I think it works well because I tried with another Android smartphone (the oldest one). And also fastboot gave me a lot of errors on my FP1U but nothing with the oldest phone. :frowning:

@Johannes i never used a SD card before. But I don’t understand, if you remove an old SIM card from your phone the data partition becomes readonly? That’s right?

No, what I meant is that a defective SIM card sometimes causes the phone to do weird things. I was wondering whether you’ve checked that the problems that you are experiencing also occur when you remove the SIM card(s) before starting the phone.


The EMMC was broken and the Tech support suggested me to send my FP to them. It was under warranty and they replaced completely the MB and now my FP is again on my hands!
Thank you very much to everybody, especially the Customer service.