English

FP1(U) root disappeared for some apps

Continuing the discussion from An unrooted OS version for fairphone:

Hello,
as the banking app DKB card secure on the FP1(U) is not working on rooted phones, I tried to unroot my FP with SuperSu (according to http://www.giga.de/apps/android/tipps/root-entfernen-anleitung-fuer-alle-android-geraete/) before I found the explanations in this forum. Of course that didn’t help, but I’m afraid it might somehow have half - deleted the root anyway:

After having checked the posts here, I tried Root Cloak unsuccessfully. Then I wanted to try XPrivacy as suggested here (http://www.hackuniverse.de/tipps/dkb-pushtan/), but the istallation failed because no root was found. Xposed also is “inactive” and it’s not possible to activate it.

So, apperently, for DKB card secure, my phone is rooted, and for XPrivacy/Xposed, my phone is not rooted (anymore).
Does anyone know what I can do about this? Do I need to re-root my FP somehow? I would be greatfull for any suggestions!

Best regards
Regina

Probably your system still have the su binaries, but, as you have no superuser manager app, no app can earn superuser access.

If you can confirm that to me (e.g. inspect that directories with Amaze), I can adapt this flashable ZIP to help you unroot your phone easily with a custom recovery.

Hi Roboe,
thank you, that would be great. I couldn’t find a superuser manager app on the amaze app amanger (at least no app called anything with superuser in it) an in the settings, it is not possible to activate the root explorer. So I guess your diagnosis is right.

Will this also work for a Fairphone 1?

Probably, it just removes two files, thus I need someone to check if su binaries are located at /bin/su and /xbin/su because I don’t have a FP1.

Also, does the FP1 has TWRP available? If there’s only CWM recovery I’ll need to sign the ZIP (TWRP doesn’t check the ZIP signature at all).

They are located at /system/bin/su and /system/xbin/su respectively.

There is only CWM, but it can install unsigned ZIPs (I have successfully done so).

Installation of CWM: Get adb and the recovery.img (forum link) and then flash the recovery following this tutorial. Mind that you’ll have to use recovery.img rather than recovery-cwm-fp1-0.2.img in the adb push command.

Ok, great! Thank you, @Stefan, :smiley:

It should work as is, then, :slight_smile:

I’ve updated the unroot-fp2-open flashable ZIP to fit FP1:
https://github.com/WeAreFairphone/flashable-zips/releases/download/unroot-fp2-open_v0.1.1/unroot-fp1.zip

I recommend to make a backup of your system partition (at least) with your recovery before applying the ZIP, just in case.
You can check if your device is fully unrooted with Root Verifier or similar. It should display no superuser manager app and no su binaries are found in your phone, :wink:

1 Like

Thank you very much, Roboe and Stefan! Unfortunately I have to leave now, I’ll try it tomorrow and tell you the results.

1 Like

Try it when you have some spare time, there’s no rush, :slight_smile:

Hello, unfortunately my efforts to try your ZIP are already failing on the first step : [quote=“Roboe, post:7, topic:23432”]
make a backup of your system partition (at least) with your recovery before applying the ZIP
[/quote]
Could you please point me to some instruction how to do this? I only found this: https://fairphone.zendesk.com/hc/en-us/articles/201190847-How-to-backup-and-restore-your-Fairphone-1 , but I don’t have a MicroSd card,and if I understand correctly, manually moving files will not do the trick.

Have you installed CWM recovery? Here is a guide on doing a backup using CWM. If you don’t have a MicroSD card, CWM will create a directory on your phone called clockworkmod. You can simply connect your phone to your PC and move the folder there.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.