[FP1(U)] Baseband software unknown

Hi all… i have just installed mobileuncle through which i have to update it. but unfortunately, i got error and afwards i got no signals on both sims card… it fairphone 1st edition repartioned with 1.8.7 kola nut… sorry for poor english


i am afraid i do not really understand your problem. We are a very internatioal community. Maybe you try to ask your question in your home language?

1 Like

Hi Ben
Thanks for early response. I already apologized for my poor English. Now let me explain my Fairphone First Edition (Re-partitioned) phone problem again. I have FP1. I have to update this phone via Mobile Uncle software. but its failed. when i rebooted the phone, i noticed that my phone has no network signal as well as invalid IMEI message by entering *#06# command. I carried the phone to the software engineering but he said that there is no baseband version in the phone and it has to re-install the baseband version. They could not find the baseband on the internet nor in their database. Beacuase FP1 is not a popular phone here in pakistan.
in the above scenario, your help was requested

I’m not sure you’ll find separate baseband packages. I’d try a hard reset (this will delete all user data, so backup first) from recovery. If that fails, recovery files (and failing that, image binaries) are available here.

1 Like

Thanks Brother for early and positive reply
I m trying the same as you said. I will inform you if it worked

Hi Johannes… thanks for your valuable suggestions. i tried all files contained on site you suggested relating to binary images but all in vain or may be i did wrong procedure for installation. i just downloaded all files (four files in binary images) and copied to SD card 1 i.e. memory stick. rebooted the phone and pressed “install from SD Card”. But it could not resolve my problem. if the above method is wrong you may kindly be requested to explain the method. thanks in advance

Having re-read the thread, I think your problem may be different from what I originally thought - I’m not 100% sure whether flashing the binary image will solve it, and you should only try to do that if you completely understand what you’re doing. You mention software engineering - maybe they can tell you if they can use the binary image to fix your phone. Also, you could open a support request with Fairphone (this forum is a community forum, and responses here are not responses from fairphone).

The instructions on the page I linked to, are the instructions for using the recovery files on that page. If the recovery files don’t work, you can consider to flash the original firmware, which is what the binary images are for. You’d only need a single file, which one depends on the partition layout (original FP1’s had a different layout). I was assuming you’d be familiar with the procedures, as you’re using MobileUncle, which looks like something that you’d only know about and use if you know about firmwares etc. If, as a last resort, you do decide to flash the binary images, there’s a basic explanation of the procedure over on XDA, here - see under “How to restore Fairphone if you totally bricked it”.

1 Like

Thanks again Johannes… I followed the instruction described on the page you quoted and I got my phone back. It did work for me. I flashed my FP1 via SP Flash tools under the topic “How to restore Fairphone if you totally bricked it”. If someone is facing the same problem he may be advised to follow the instruction http://forum.xda-developers.com/wiki/Fairphone_Fairphone/Guides#Bricked_your_Fairphone.3F

Once again I really appreciated your valuable comments / suggestions and special thanks to Johannes.