FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

A darker boot animation is a great idea. I never update the OS in the evening because I hate rebooting when it’s dark.

@YtvwlD I guess this boot animation will work with the FP2 too right? Could you share it here too:

I hate (re)booting the phone in the morning when it’s dark. :slight_smile:

I think, it’ll work with the FP 2, too. But if the screen resolution is different, it might look weird.

I could apply my script to the FP 2 bootanimation.

edit: No, they’re the same.

edit 2: link

1 Like

Has anybody tried ART, yet?

I’d like to, but I can’t make nandroid backups because my phone is encrypted.

Doesn’t work (when I reboot it’s still in Dalvik mode). It seems that it is not included in the build…

1 Like

What is the status of 4.4.4 and the security fixes?

I’ve switched from a ROM that has had fixes up to last June, because that seemed like a long time ago.

Now, there are none.

And the remote code executions (and fixes) are coming.

1 Like

I’ve read a bit through the logs and several components are a bit too noisy. This is nothing new in this build, but perhaps it can still be fixed.

W/InputReader( 1592): inCount:16, pointer count:1

This occurs on every touch. And it is not a warning.

E/CellLocation(15771): create GsmCellLocation

This occurs regularly. And I don’t think this is an error.

But there are things that look like errors:

W/AppsProvider.ApplicationsProvider( 4496): Could not fetch usage stats
W/AppsProvider.ApplicationsProvider( 4496): java.lang.SecurityException: Neither user 10008 nor current process has android.permission.PACKAGE_USAGE_STATS.
W/AppsProvider.ApplicationsProvider( 4496):     at android.os.Parcel.readException(Parcel.java:1465)
W/AppsProvider.ApplicationsProvider( 4496):     at android.os.Parcel.readException(Parcel.java:1419)
W/AppsProvider.ApplicationsProvider( 4496):     at com.android.internal.app.IUsageStats$Stub$Proxy.getAllPkgUsageStats(IUsageStats.java:237)
W/AppsProvider.ApplicationsProvider( 4496):     at android.app.ActivityManager.getAllPackageUsageStats(ActivityManager.java:2224)
W/AppsProvider.ApplicationsProvider( 4496):     at com.android.providers.applications.ApplicationsProvider.fetchUsageStats(ApplicationsProvider.java:714)
W/AppsProvider.ApplicationsProvider( 4496):     at com.android.providers.applications.ApplicationsProvider.updateApplicationsList(ApplicationsProvider.java:548)
W/AppsProvider.ApplicationsProvider( 4496):     at com.android.providers.applications.ApplicationsProvider.access$400(ApplicationsProvider.java:72)
W/AppsProvider.ApplicationsProvider( 4496):     at com.android.providers.applications.ApplicationsProvider$UpdateHandler.handleMessage(ApplicationsProvider.java:227)
W/AppsProvider.ApplicationsProvider( 4496):     at android.os.Handler.dispatchMessage(Handler.java:110)
W/AppsProvider.ApplicationsProvider( 4496):     at android.os.Looper.loop(Looper.java:193)
W/AppsProvider.ApplicationsProvider( 4496):     at android.os.HandlerThread.run(HandlerThread.java:61)

and

W/System.err( 1597): java.lang.SecurityException: WifiService: Neither user 10121 nor current process has android.permission.CHANGE_WIFI_STATE.
W/System.err( 1597):    at android.app.ContextImpl.enforce(ContextImpl.java:1780)
W/System.err( 1597):    at android.app.ContextImpl.enforceCallingOrSelfPermission(ContextImpl.java:1809)
W/System.err( 1597):    at com.android.server.wifi.WifiService.enforceChangePermission(WifiService.java:637)
W/System.err( 1597):    at com.android.server.wifi.WifiService.getWifiServiceMessenger(WifiService.java:1291)
W/System.err( 1597):    at android.net.wifi.IWifiManager$Stub.onTransact(IWifiManager.java:424)
W/System.err( 1597):    at android.os.Binder.execTransact(Binder.java:404)
W/System.err( 1597):    at de.robv.android.xposed.XposedBridge.invokeOriginalMethodNative(Native Method)
W/System.err( 1597):    at de.robv.android.xposed.XposedBridge.handleHookedMethod(XposedBridge.java:631)
W/System.err( 1597):    at android.os.Binder.execTransact(Native Method)
W/System.err( 1597):    at dalvik.system.NativeStart.run(Native Method)

and

W/Bundle  ( 1597): Attempt to cast generated internal exception:
W/Bundle  ( 1597): java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:1000)
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:982)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$AudioProfileHandler.handleMessage(AudioProfileService.java:3395)
W/Bundle  ( 1597):      at android.os.Handler.dispatchMessage(Handler.java:110)
W/Bundle  ( 1597):      at android.os.Looper.loop(Looper.java:193)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$OverrideSystemThread.run(AudioProfileService.java:3363)
I/System.out( 2186): [CDS]close[0]
I/RingtoneManager( 1597): Set actual default ringtone uri= content://media/external/audio/media/54612
W/Bundle  ( 1597): Key 8 expected Integer but value was a java.lang.String.  The default value 0 was returned.
W/Bundle  ( 1597): Attempt to cast generated internal exception:
W/Bundle  ( 1597): java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:1000)
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:982)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$AudioProfileHandler.handleMessage(AudioProfileService.java:3395)
W/Bundle  ( 1597):      at android.os.Handler.dispatchMessage(Handler.java:110)
W/Bundle  ( 1597):      at android.os.Looper.loop(Looper.java:193)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$OverrideSystemThread.run(AudioProfileService.java:3363)
I/RingtoneManager( 1597): Set actual default ringtone uri= content://media/internal/audio/media/106
W/Bundle  ( 1597): Key 16 expected Integer but value was a java.lang.String.  The default value 0 was returned.
W/Bundle  ( 1597): Attempt to cast generated internal exception:
W/Bundle  ( 1597): java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:1000)
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:982)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$AudioProfileHandler.handleMessage(AudioProfileService.java:3395)
W/Bundle  ( 1597):      at android.os.Handler.dispatchMessage(Handler.java:110)
W/Bundle  ( 1597):      at android.os.Looper.loop(Looper.java:193)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$OverrideSystemThread.run(AudioProfileService.java:3363)
I/RingtoneManager( 1597): Set actual default ringtone uri= content://media/internal/audio/media/106
W/Bundle  ( 1597): Key 2 expected Integer but value was a java.lang.String.  The default value 0 was returned.
W/Bundle  ( 1597): Attempt to cast generated internal exception:
W/Bundle  ( 1597): java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:1000)
W/Bundle  ( 1597):      at android.os.Bundle.getInt(Bundle.java:982)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$AudioProfileHandler.handleMessage(AudioProfileService.java:3395)
W/Bundle  ( 1597):      at android.os.Handler.dispatchMessage(Handler.java:110)
W/Bundle  ( 1597):      at android.os.Looper.loop(Looper.java:193)
W/Bundle  ( 1597):      at com.mediatek.audioprofile.AudioProfileService$OverrideSystemThread.run(AudioProfileService.java:3363)
I/RingtoneManager( 1597): Set actual default ringtone uri= content://media/internal/audio/media/74

This doesn’t impair the usage in any way and they have been there before this ROM, but I don’t think having things crash randomly in the background without anyone noticing is the way to go. :slight_smile:

1 Like

I have the exact same problem. My promity sensor only displays those two values and as a result my screen doesn’t go black when I hold my phone to my ear.
My proximity sensor may be a bit broken (because I had my broken USB port repaired), but it worked enough for the last ROM to detect whether my phone is near my ear or not.

The sensor has never put out any other values than 0 and 1. So SatStat is not displaying any distance, but rather covered and not covered

3 Likes

My OS still feels quite slow. Never had issues before the alpha. But now it might take like 3 secs to load the menu for calling. Since no one reported this yet as it seems, i think it is a individual problem here.

My situation is that I have to wait some seconds after pressing the call button until the call actually starts. It was solved when I switched to Kitkat, but it has returned at some later point…

Yeah this occurs here, too.

Another thing that really annoys me is that the notifications seem to be very broken. Some apps don’t seem to show any notification anymore (like twidere for twitter). Others like ebay kleinanzeigen or signal seem to update only when i turn internet off and on again or switch from wifi to mobile internet.
I don’t know if this might have something to do with but i am playing animation throwdown and whenever i switch from 3G to wifi or back it restarts the app and says that the time of the device changed so it has to restart. Could this be connected to my problem above?

It worked for me without having to re-enter the settings (WPA2-Personal and WPA2-Enterprise).

But there are a few problems:

  • Sometimes I loose connection. This is probably a combination of the building I’m in, using 2.4 GHz and the other people who use it, too. This happens with other devices, too.
  • After a few hours of having connection, loosing it, reconnecting and so on, my phone won’t reconnect. It simple stays on mobile (which mostly isn’t available in the building). The wifi settings say “Disconnected.”. I guess that it gives up after a few times loosing connection. I would count being connected for more than 5 minutes as successful.
  • Sometimes when using memory intensive apps (e.g. Firefox), I’m loosing wifi. The connection goes away and there are no available networks listed in settings, only the known ones. This goes away when I disable and re-enable wifi. I guess that wpa_supplicant is killed when the system runs out of memory.

@NeoXtrim are you using Google Services? If push notifications don’t work, it is probably because GCM’s configuration is defunct.

1 Like

Anybody here, who has the Bose Quietcomfort 35 headphones and can test the microphone quality during calls? We are trying to figure out what’s the problem here.

How can I install that? Since upgrade /manual install of 4.4.4 i get the "android"
bootloader. Not a problem, but I like yours a lot.

Sadly I don’t know why it doesn’t work.

It works for me in an Android emulator (at boot and when run with bootanimation).
On my FP1 it only works when I execute bootanimation after bootup. It won’t show during boot. :frowning:

I deleted your post in the #kitkat -FAQ. Please ask development questions here (like you have done).

THX. I really have problems following the right threads here. I don’t really have an overview where I am, most of the time.

Were is this “android” bootanimation.zip stores at?
And how can I get the Fairphone updater for #kitkat without gapps?
The rest works fine, I’m about to use my FP1 as my main phone again.

Hi everybody, haven’t read you for sometime and if my comment is redundant I’m sorry.

I get very weird behavior from my phone:

Notifications are completely non reliable… sometimes they appear normally sometimes I only get messages when I unlock my phone.

Phone is in silent mode but a video clip sent to me via whatsapp can be heard (and pretty loud).

Applications like “BBC News” crash without reason after 1 sec or after several minutes… or not!

I have the same problem other reported about delay when phone rings and being able to answer it. Same delay when I’m the one calling.