FP1 1.6 SD card & Phone storage not recognized (Partitioning problem?)

I have some major issues with my FP1 that render me unable to use the phone and even block all attempts to fix it.

  1. When trying to open the camera app, backup app, trying to download something, etc, it tells me “no external storage available”.

  2. Trying to install the Google apps does not work. When opening the link on the homescreen and accepting the terms, I get the message “Unfortunately, Fairphone OS has stopped”. Maybe also the storage issue?

  3. After putting a sd card into the phone, I still get the same problems as in (1) & (2) and the card does not show up under Setting -> Storage. Weirdly, also the Phone Storage section is empty here. Only Internal Storage is available with allegedly 13,26gb free space, which I am not able to access, File Manager offers me sheer emptiness.

  4. The 8gb SD card works fine on Windows 10. I’ve been extra careful to format it in Fat32. Nothing on the phone.

  5. When connecting the phone to Windows 10 via USB, I can see it in the file explorer, but I cannot see any files on it nor can I copy anything there.

  6. I am aware that my phone seems to be affected from some partitioning issue and that there are possibilities to resolve this using an app called “Meteos MTK6589 ROM EDIT”, but there is no way for me to even get this app on my phone nor install it!

I am seriously lost here and appreciate any help.

  1. First of all, please don’t attempt to repartition your phone as you might brick it.

  2. The latest version of Fairphone OS is 1.8.7. Update to the latest version using the Fairphone Updater. (If it fails due to storage issues, you’ll have to sideload the update from your PC. If you manage that your FP1 recognizes the SD card, you can also install the update manually.)

  3. What you are experiencing is indeed a problem with phone partitions. To resolve this issue, Fairphone has released a Storage Upgrader. It will unify your phone partitions, but it will also delete everything that is stored on your phone. So make a proper backup (the preinstalled backup app does not backup everything) and follow step 2. You should then be presented with the Storage Upgrader option in your Fairphone Updater. (Again: If you experience problems, you can sideload or manually install the upgrade, as mentioned in step 2.)

PS: you could have found all of this information using the search feature of this forum. Click the little magnifying glass above to search the forum. :wink:


Thank you so much!

  1. I am happy if I can avoid this.

  2. I will try to sideload the update, no chance into getting the phone to recognize any SD.

  3. No backup needed, since I’m not able to store any data on the phone so far…

And yes of course, I have searched. Searched alot. Took my quite a while until I was desperate enough to open up this account. Guess I gotta work on my search-game! :smiley:

1 Like

You could try to reformat your SD with the phone. Sometimes that’s necessary in order to get it recognized. Go to System settings–> Storage --> Erase SD card.

Thanks, but the SD card is not showing up in the phone storage settings.

Did you already try to take it out, clean the contacts and put it in again?

Yes. I have 2 SD cards here, 2 and 8gb. They both work flawless on my laptop and another android device.

If you are not concerned about data loss1, you might as well go the easy route and Clear Data of your phone. To do so boot your phone into recovery and select Clear Data. Then select Reboot. All data will have been erased and you should be able to download and install the update via the Fairphone updater. Remember that your screen hast to be active during the whole process2!

1 Be aware that app data also is deleted (I’m not sure if you have any apps installed).
2 You can go to Developer Options > Stay awake and plug your phone in to keep your screen active.

Thanks. I missed to note that I have also already tried that. The problems described in my first post remained the same afterwards.

Hi! I have the same problem with my Phone storage. But everytime I try to open the article about the unified storage, I get an error. For some kind of reason I’m not allowed to access the article. Now what? So I have no clue how to fix this problem. Anyone an idea?

What’s your OS? Cherry 1.6 or Kola Nut 1.8.7 or something older?

Hi Irina, Thanks for your reply. I have Kola Nut 1.8.7.

Here’s the link to the tutorial: https://www.fairphone.com/tutorials-en/#/manufacturer/fairphone/device/fairphone/category/software-update/topic/install-storage-upgrade-for-v1-8-7/1. It’s also available in German, Dutch and French.
I hope it works now.

Thanks a lot. This one works! Hurray

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.