FP specific problem with Twitter App

I have a very special issue with the standard twitter app from the appstore on my fairphone: after every reboot of the phone the accounts registered with the app got lost, so I have to reenter all the account credentials after every reboot.
It doesn’t matter whether I create the accounts from within the twitter app or from the System-Options accounts section, they are lost after reboot.
Other accounts (evernote, dropbox, whatsapp, threema) are permanent and not effected by reboots.
On 5 other devices (Motorola Defy, HTC Desire, Galaxy Nexus, Galaxy Note 8.0 and Galaxy Tab 10.1) this twitter-account-reboot-effect isn’t an issue, so it’s seems to be FP specific.
I have the first version of the FP and the problem was already there with SW Verison 1.3 and it hasn’t changed with last weeks update to Cherry.
Has anybody here a similar problem or any idea, how it could be solved?

Tried this on my FP1U, also with the update to 1.6 Cherry.
After restarting the phone my twitter account did not get lost. I opened the twitter app and my account was still registered the same as before.
Or do you mean not restarting the phone, but actually turning it off and then on again? (Not sure if it makes a difference)


Hi there @RRg,

I use the twitter app as well and I’ve just restarted (power off - power on) my phone and I don’t seem to have any problems. Try clearing the cache and data (Settings > Apps > Twitter), then restart your phone and sign in (this time it’s normal you’ll have to sign in) then restart your phone again and see if the problem still exists. If so, maybe completely try re-installing the Twitter app.

If your problem isn’t resolved by this, please let me know. I’ll try and find a solution or maybe we could notify the support team.

Kind regards,


1 Like

I have moved this topic into the Fairphone Help! category to make sure it is easy for others to find and offer help

Thanx for the hints. But that procedure hasn’t yet solved the problem. The twitter-account still gets lost with every new start of the system.
Additional Infos: the twitter app is not residing in the internal memory but in the phone-memory (“Telefonspeicher” like it’s called in the german version of Settings, App-Info") as this was proposed by clean-master and AppMgr III. The data and cache clearing nevertheless affected both memory types. Moving the app back to the internal memory is currently not an option, as I’ve not yet applied the MTK memory repartition.
I have installed the xposed framework and xprivacy on the FP, but the twitter-app has currently no access restrictions assigned.
What else could affect a bevaviour like this?

Best regards,

Hi Robin,

I still experience the same situation. Do you have any more hints, what I could try to resolve this or do we have to involve a dedicated support expert?

kind regards,

Hi @RRg,

have you tried the following hints from the Twitter website: Link?

I don’t think this is a Fairphone specific issue but an issue with your personal software and storage setup.



P.S.: Personally I suggest to use a third-party app like Twidere or Talon.

1 Like

@RRg - If you want to raise this to Fairphone Support to get someone to look at this officially, you can do this by going to the support page and raising it as a question

Hi Tom,
I’ve already checked that.
On my Samsung Note 8.0 tablet I have a very similar setup (android 4.3, root, xposed, xprivacy …) but here the twitter app is able to keep all the accounts even through shutdowns & reboots

Twidere is fine for some aspects, but I miss some features!

Hi @RRg,

well that’s bad.

Then get in touch with the support as @Chris_R suggests. Personally I have no other idea.



1 Like