FP shows Invalid IMEI


My new FP doesn’t get any network, no 3G, nothing at all. I already tried several SIM cards (in both slots) and spent a few hours reading in the forum. I also checked all the proposals from the topic “3G not working”. It shows “invalid IMEI” as start notification, the SIM cards are recocnized, but shown grey, no access. I suggest that it’s an hardware mistake. Anyone got an idea? Otherwise I will have to send the devise back. Sad enough…

Does nothing at all also mean you don’t get basic GSM calls? (The IMEI message sounds like it.)

I assume this did not happen out-of-the box?

It sounds like the IMEI numbers have not installed correctly on your handset. The IMEI is a unique number that links to your phone. You can find your IMEI numbers printed on the sticker on the box your Fairphone came in. There are 2 IMEI numbers, one for each SIM slot

There is a fairly straightforward way of correcting these as the Fairphone is rooted, however it is a technical guide so I would suggest having a read through and seeing if you are comfortable doing… if not, you will need to contact Fairphone Support directly as I think they would need the phone back to correct this for you.

Sound’s very sensible to contact support rather than to start fiddling with the IMEI. It might be illegal in your country.
I’d really like to know if you did or changed something before this happened!

The phone wasn’t working properly from the beginning. It took me a while to realise that it shows “invalid IMEI” while locked. I took no trials to correct the IMEI. 2 days ago I already contacted Fairphone support. Didn’t receive an answer yet.

Response times at support are a bit slow at the moment, due to the limited resources of the FP team. I think the guys over there are doing their best.

Thanks to @Chris_R! I gave it a trial and now it’s working proper. It’s making much more fun now. Ciao


Glad to hear this worked for you

This topic is now closed. New replies are no longer allowed.