Forum using (mobile) Firefox browser

A workaround is

a. Do not click anywhere until the post has fully loaded. Best not even move your mouse, if on desktop. :wink:
b. And if you click on the post number which displays in the lower right corner (e.g. 10/10), there is a shortcut to the last/first post.

1 Like

Sorry for resuming this old post but I can confirm navigating and editing posts on FP with Firefox is terrible!!!
Hope this will be fixed soon :smile:

There is a topic discussing scrolling in Firefox Mobile further. It’s a very interesting read. Basically we found out, that it started after Firefox Mobile 32 and that it is caused by JavaScript (disabling Javascript renders the Fairphone Forum completely useless though…).

1 Like

Thanks! Its very strange I found this thread regarding Firefox issues, but the forum didn’t notify me of new posts in the thread you linked the very same day :confused:

When I would like to open a thread the screen left white… Just the rotating circle…
And yes, some month ago the problem did not exist.

Any help?


@Dosc You should check this thread: I cannot view posts on mobile when logged in. You most probably will find out, that this does also occur with any other browser you will try. The worst part of it is that there is no obvious pattern.


Thanks, happy to see I’m not the only one…

Me too, but I suppose (didn’t try though) this depend on the problem mentioned in the @Stefan linked post

The mobile experience of the forum is still not great.

  • I can’t scroll on popups, so if a button on a popup is not being displayed right away I can’t get to it. (Sorry I don’t know how to describe this better, I’ll add a screenshot later. @Stefan @Chris_R you can try and reproduce this next time a spambot-post needs to be approved. When you click “delete user” a popup will appear but you can’t get to the button to confirm)

  • I also can’t send “new messages” because I can’t get to the field to add a user to write to.

1 Like

I don’t have problems with the spam-popups. Also I can add users to recieve-field in a pm. I’m on Fennec F-Droid 39.0.2

Another weird thing I discovered though:

At first it is only 10 characters as a limit and then Discourse wants 20 again.

PS: I guess this is not a mobile specific.

1 Like

This is what it looks like when I abandon a post on mobile. The botton is still visible and can be used, but with other popups some buttons are hidden.

About the messages: If I hide the keyboard I can get to the field where I can enter a username. When I click into the field the keyboard is back and the field can’t be seen again. I don’t see what I type but fortunately suggestions pop up downwards so I can choose the recipient.

1 Like

I can’t reproduce your issue. See my “abandon”-message:

Edit: You know what’s your problem? You have “Desktop-site” checked in Fennec’s menu… :wink:

1 Like

Nope. But whether I have it checked or unchecked doesn’t make a difference in that regard.
I just disabled all addons and tried again: no difference. But strangely after I disabled the addons and quit Fennec the keyboard showed up.
I also disabled all Xposed modules, just in case. Still no difference.
I’m using Fennec 40.0, but I’m pretty sure I had these problems before

1 Like

Then press the hamburger icon and choose the equivalent of “desktop view”.

I can see from your screen shot, that you’re in desktop mode! :wink:

1 Like

Ah you’re right! Much better.
Apparently there are 3 modes:

Fennec’s Desktop mode

Fennec: mobile but Hamburger: desktop

Fully mobile.


So what’s the current status/issue? @paulakreuzer @Stefan

This one seems solved with the latest Discourse version:

As a moderator however I cannot move posts, when I am on the forum using Fennec F-Droid (mobile Firefox). The issue is negligible though, since it affects only moderators.

1 Like

Alreade since the beginning of this nice new forum, I am not able to relyable COMPOSE any post at my FP1/Firefox (indeed Aurora channel), since the slow reacting cursor drives me crazy.
Having the FP1 in horizontol orientation I can’t even see what I am typing…

Unfortunately it is the same now witht the FP2/Firefox (Aurora channel).
At Desktop-PCs with Firefox I have these problems not!

And I guess it is intended behaviour, that in mobile versions there all formatting buttons are not available? Makes it rather useless in my opinion…

Cheers, Robert

A solution to this would be a hardware keyboard… :yum:

Maybe this helps: Markdown Cheatsheet (markdown is the formatting language used in Discourse).

There is also this thread:

Note: Insert emojis works in the latest Discourse version, if you click on the smiley-button. The drop-down, when you start typing a colon, does not work however (as I stated here).