Flashlight not working / releases at wrong moment

Hi fellow FP4 users,
I’ve had a flashlight problem with OpenCamera on my FP4 and found a solution. Maybe this helps if someone has a similar issue.

This is my phone setup:

  • iodeOS 3.0 (3-20220530-FP4)
  • OpenCamera 1.49.2 (F-Droid version, not the preinstalled from iodeOS)

And that was my issue:
Whenever I wanted to take a photo where the flash should be activated the flash was activated but a little too early. So in the resulting photo the flash was already off again and the photo was much too dark.

This is what solved my issue:
I activated the option “Use alternative flash method” in the OpenCamera app. (OpenCamera app → settings → Photo settings → Use alternative flash method)

For reference, the iodeOS version of OpenCamera did not show this issue in the first place.

1 Like

I never have a problem to use the flashlight. Or do you use itt toghether with the camera?
I have never tried that. Just don’t film at night :slight_smile:

It is a old well known bug and fixed default in iode, longer time ago.
Not only for FP4. Was also a problem on my wife’s opo 6t.
To fix it that way, is already well known.
Or to use not open camera. Can be fixed that way in some older gcam ports as well, or already hard coded in newer ports.

Nevertheless, thanks again to bring it up…