English

Flashing LineageOS is not working

I did reset beforehand, thanks. Forgot to mention that :wink:

Unfortunately when having flashed the recent LineageOS version I cannot access the device via adb because lack of authorization.
Is there a way to authorize my laptop prior to booting the (newly flashed) system?

EDIT: I know I can add my adb pubkey to the FP2 /data partition, but in order to boot a new system /data should be wiped right?

If you enter the following command from the recovery, it will disable the adb key authorization: sed -i 's/ro.adb.secure=1/ro.adb.secure=0/' /system/build.prop

Okay, I really do not know what exactly is happening, but I am not able to flash the recent lineageOS version with the TWRP delivered with the FPOpenOS version anymore. So no testing and no logcat, sadly. I read in the thread regarding the LineageOS port, that there are new blobs now coming with sibon-17.07.6? Maybe the now blobs can help with the issue?

EDIT: AFAIK recent lineageOS builds are shipped with blobs from sibon-17.04.8 so maybe an update of the blobs could help?

Thanks for mentioning.
I am actively following the process of development.
Tried the recent LineageOS build from 03.08.17 and the testbuild from 05.08.17.
The first is targeted to blobs 17.04.8 like the ones before. As expected the blue screen is there also. No adb to log something.
The second is also targeted to 17.04.8 but does not flash properly. Flashing stops after data is written and TWRP does not end the flashing process as normally expected. Trying to reboot causes FP2 to bootloop.
I am ashamed I cannot contribute more as of today, because exams are awaiting me coming wednesday. After that I will try to build LineageOS for FP2 myself.

1 Like

Hi!

I think I know what @Roboe meant with this:

See here and the following posts. Especially this:

And @Lazalatin wrote he has this new version:

So I think he has one of the first devices with this hardware change, and LineageOS is not (yet) ready for these devices.

Maybe @rick can contact @chrmhoffmann and tell him what to change for these new devices? This would be really great! :wink:

4 Likes

This is exactly what @Roboe meant I think! (It also makes sense, despite that info :wink: )
I hope this can be fixed soon :slight_smile:
I will stay close to the Porting threads of the forum^^

1 Like

Hey Lazalatin,

you’re not alone. I just received my FP2 yesterday, also a delayed delivery. Software version was FP2-gms-17.07.6.1 Today I tried to flash a recent TWRP (3.1.1-0) from the official TWRP site. When trying to enter the recovery mode with this, I get a blue screen too. Also, as you mentioned, the TWRP included in the fp2-sibon release works on my phone. After reading this thread I tried the newest available LineageOS build (lineage-14.1-20170808-UNOFFICIAL-FP2.zip) with the same result: a blue screen.
So I guess we have to wait for the new LCD driver to be integrated into TWRP and LineageOS.

2 Likes

So we’ll have to summon @z3ntu here too, he’s the maintainer of the FP2 TWRP-Port. :wink:

1 Like

I’ll work on updating the TWPR port soon.

2 Likes

Great!
Thank you @z3ntu :slight_smile:

I merged in the new changes for the kernel. It would be good to give it a new try. There’s also a new panel support or something like that. @z3ntu you should also do new twrp then :slight_smile:

Chris

7 Likes

And thanks for @z3ntu to ping me on this.

2 Likes

I tried basing TWRP on the omnirom 7.1 branch (with modified lineage device and kernel) but the resulting recovery.img doesn’t boot at all…

Can you please flash the recovery.img from https://private.z3ntu.xyz/fairphone/TWRP_3.1.1-0-new-kernel/ to your recovery partition and report back if it’s working? Thanks.

CC: @Lazalatin

7 Likes

Kudos to you, it works!
My hopes and dreams have been heard and fulfilled! :heart:
Much love to you all :slight_smile

EDIT: Is this new version still backwards compatible for all FP2?

5 Likes

Yes, it works on my phone too :slight_smile:

I installed this new image, and TWRP still works (with encryption, too).

Since the TWRP version number is still the same … In TWRP terminal uname -a is giving “Linux localhost 3.4.0-gea459bc #1 SMP PREEMPT Sat Aug 12 23:00:45 UTC 2017 armv7l GNU/Linux”

I’m not too involved with Linux yet, but the date in there sounds like it really is the new kernel, right?

Yes. I built the kernel yesterday. You can even see the hostname if my computer when running cat /proc/version in TWRP. :wink:

Just tried, works like a charm. Thanks for your effort.