English

Flashing LineageOS is not working

I can safety guess that your FP2 is shiny new? Which FP OS version it came with?

I may have a theory, but as it involves some sensitive, non-public Fairphone info (yet), I’ll contact the person who trusted me that info and ask for permission to share it in the public. It has to be with hardware and would explain your situation, if I’m not wrong.

Could you try an older FP Open 5.1 release in the meantime? The last 5.1 manual ZIP is here: https://storage.googleapis.com/fairphone-updates/a88b516b-d990-4219-aef1-c23b3c30c104/fp2-sibon-17.04.0-manual-userdebug.zip (don’t forget to wipe your data first, as it’s not backwards compatible). You should see an equally blue screen once booted, if my theory is true.

2 Likes

Yes, I am sure, because my delivery was delayed due to the display shortage with Fairphone2 models. This device was delivered with the most recent FairphoneOS FP2-gms-17.07.6.1

EDIT: I will tried out and most interestingly the outcome is even worse. The device rumbles on turning on but the screen stays dark the whole time. No startup splash, nothing. I will return into fastboot mode and reflash the recent Android 6.0 FairphoneOS.

EDIT2: I forgot to wipe beforehand. Stay tuned…

EDIT3: Wiping is not possible due to the fact that I can not get into recovery or use adb while the phone is detected. So this is all I can tell now.

1 Like

Ok, fine, that fact should prove my theory correct. I’ll return with the info later when I get the permission to share, or some FP staff will reply here with it. Sorry for the delay involved, I don’t want to leak anything to the detriment of Fairphone.

1 Like

Thats fine to me. Thank you all for your time and work!
I am looking forward to hearing from you.

1 Like

Oops. It seems like my theory does not correspond with your issue after all because the information I had was about a development process not deployed yet. So… I’m out of ideas now, :confused:

1 Like

Well, same here. I am quite sure I tried everything in order.
But just to be sure I will retell my try here, maybe someone notices an error.

  1. I tried flashing the TWRP with OTA Fix as it can be found in this thread via fastboot. This attempt failed, as the screen turns blue when booting into recovery, but the phone is recognized via MTP.
  2. I tried flashing a TWRP without this Fix, directly downloaded at TWRP Project website. Same result.
  3. I learned that Open Source FairphoneOS is delivered with TWRP preinstalled. Its Version is older (3.0.2-0 instead of 3.1.1-0 from point 2), but works like a charm. So I flashed the Open Source FairphoneOS, which works.
  4. I tried flashing LineageOS for FP2 as described in this thread using the TWRP I flashed at point 3. Trying to boot the flashed LineageOS also ends up with that blue screen from points 1&2.

So I finally decided to stay with OpenSource FairphoneOS because I am in control of my device then and can make a living without Googles “Services”. But I would like LineageOS 14.1 to run on my device, because I started to like it on my tablet. Maybe someday, someone has an idea about this. Maybe I forgot to make a vital step while flashing, I have no idea…

But anyway: Thanks for your investigation @Roboe :slight_smile:

1 Like

It doesn’t seems like that. As you don’t have issues with official software, FP Support won’t give you further support, naturally.

Better ask known community developers to help you debug that. Could you @z3ntu look at this? I’m not sure how to get logs or dmesg or something to debug low-level thingies.

Just to be shure: You didn’t forget to do a factiry reset within TWRP, before flashing the LineageOS on to your device?

If adb is available while booting, the output of adb logcat would be the most important.

1 Like

I did reset beforehand, thanks. Forgot to mention that :wink:

Unfortunately when having flashed the recent LineageOS version I cannot access the device via adb because lack of authorization.
Is there a way to authorize my laptop prior to booting the (newly flashed) system?

EDIT: I know I can add my adb pubkey to the FP2 /data partition, but in order to boot a new system /data should be wiped right?

If you enter the following command from the recovery, it will disable the adb key authorization: sed -i 's/ro.adb.secure=1/ro.adb.secure=0/' /system/build.prop

Okay, I really do not know what exactly is happening, but I am not able to flash the recent lineageOS version with the TWRP delivered with the FPOpenOS version anymore. So no testing and no logcat, sadly. I read in the thread regarding the LineageOS port, that there are new blobs now coming with sibon-17.07.6? Maybe the now blobs can help with the issue?

EDIT: AFAIK recent lineageOS builds are shipped with blobs from sibon-17.04.8 so maybe an update of the blobs could help?

Thanks for mentioning.
I am actively following the process of development.
Tried the recent LineageOS build from 03.08.17 and the testbuild from 05.08.17.
The first is targeted to blobs 17.04.8 like the ones before. As expected the blue screen is there also. No adb to log something.
The second is also targeted to 17.04.8 but does not flash properly. Flashing stops after data is written and TWRP does not end the flashing process as normally expected. Trying to reboot causes FP2 to bootloop.
I am ashamed I cannot contribute more as of today, because exams are awaiting me coming wednesday. After that I will try to build LineageOS for FP2 myself.

1 Like

Hi!

I think I know what @Roboe meant with this:

See here and the following posts. Especially this:

And @Lazalatin wrote he has this new version:

So I think he has one of the first devices with this hardware change, and LineageOS is not (yet) ready for these devices.

Maybe @anon12454812 can contact @chrmhoffmann and tell him what to change for these new devices? This would be really great! :wink:

4 Likes

This is exactly what @Roboe meant I think! (It also makes sense, despite that info :wink: )
I hope this can be fixed soon :slight_smile:
I will stay close to the Porting threads of the forum^^

1 Like

Hey Lazalatin,

you’re not alone. I just received my FP2 yesterday, also a delayed delivery. Software version was FP2-gms-17.07.6.1 Today I tried to flash a recent TWRP (3.1.1-0) from the official TWRP site. When trying to enter the recovery mode with this, I get a blue screen too. Also, as you mentioned, the TWRP included in the fp2-sibon release works on my phone. After reading this thread I tried the newest available LineageOS build (lineage-14.1-20170808-UNOFFICIAL-FP2.zip) with the same result: a blue screen.
So I guess we have to wait for the new LCD driver to be integrated into TWRP and LineageOS.

2 Likes

So we’ll have to summon @z3ntu here too, he’s the maintainer of the FP2 TWRP-Port. :wink:

1 Like

I’ll work on updating the TWPR port soon.

2 Likes

Great!
Thank you @z3ntu :slight_smile: