Flashing FP5 with fastboot error "Could not flash the super partition on device"

Hi, I’m trying to get back to FairphoneOS after trying CalyxOS.

Unfortuantely I’m stack on the last step (flash script).
Everything in previous steps went well, except fastboot flashing unlock_critical, it returns

FAILED (remote: '	Device already : unlocked!')
fastboot: error: Command failed

When I try to run shell script I get after a while:

Sending 'dtbo_b' (24576 KB)                        OKAY [  0.843s]
Writing 'dtbo_b'                                   OKAY [  0.103s]
Finished. Total time: 0.957s
terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::compare: __pos (which is 917456) > this->size() (which is 0)
./flash_fp5_factory.sh: line 205: 20588 Aborted                 (core dumped) ( "${FASTBOOT_BIN}" -s "${ANDROID_SERIAL}" flash "${partition}" "${image_file}" )
ERROR: Could not flash the super partition on device 49ba2508.

ERROR: Please unplug the phone, take the battery out, boot the device into
ERROR: fastboot mode, and start this script again.
ERROR: (To get to fastboot mode, press Volume-Down and plug in the USB-C)
ERROR: (cable until the fastboot menu appears.)
ERROR: Aborting now (press Enter to terminate).

After rebooting the same error is apearing again. Anyone knows what can I do now?

Update: CalyxOS flash works, no issues, I’ve installed it for time being

Assuming you’re using Arch Linux, this should be fixed since about 2 weeks: 34.0.4-1 breaks fastboot (#4) · Issues · Arch Linux / Packaging / Packages / android-tools · GitLab

Please update to the latest android-tools version if you haven’t already.


I’m on Fedora, so updating platform-tools was not so straighforward, but using the newest ones from zip worked, thank you very much! :heart:
(I’ve found in the artifacts left after installing CalyxOS that there was a package of platform-tools, so I assume that their flasher fetches and uses the latest ones automatically, which did the job in this case.)

Do you have a Fedora bugtracker account? In case please report the crash with std::out_of_range to them and link the Arch Linux bugtracker link I’ve posted, it should contain all the information how Fedora can fix the package on their side. If not let me know and I can find a way to get in touch with the packagers there.

1 Like

I created an account and reported it: 2269669 – Fastboot crashes with std::out_of_range on android-tools 34.0.4-4.fc39 (redhat.com)
(This is my first time reporting a bug, I hope everything is okay).


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.