Fixing OTA after rooting

I couldn’t quite follow you there, but broken Wifi, usually coupled with no sound and a hot phone, is usually due to running an outdated kernel. The current software version is A.116 but as of now FP only provides the A.107 kernel for manual download.

You should not manually flash a kernel, but use Magisk to patch the currently running kernel from within Android

The guide by OP is a bit misleading

1 Like

I just followed OP guide, maybe the A.103 kernel I patched with Magisk was outdated. Starting again with patched A.107 kernel works fine. Thank you.

1 Like

You shouldn’t flash a A.107 boot.img to a device running A.116, next time just follow these simpler steps to perform the OTA update:

I have already uploaded a patched boot.img for the latest release here:

If you need a stock boot.img from A.0116 I can upload that as well.

As a general rule, don’t flash any boot.img if you don’t have to, just follow the original root guide, it’s still valid.

@amoun nice thought :+1: , but that’s only the file. There is a boot.img “hidden” in there but it’s unnecessarily hard to get it out, copying one from a already updated system is way easier :slightly_smiling_face:


Thank you @hirnsushi ! I hadn’t seen that.

1 Like

Hello, I am in build A.128 and I would like to install the update to A.0142. I tried the method here FP4 Root Access is possible, maybe a bit risky - #203 by hirnsushi . Uninstall Magisk (“Restore images”) seemed to work but the OTA update always stops. Any idea?

Probably the hash of one of your partitions doesn’t match, likely a side-effect of your previous rooting problems.

Could you capture a logcat please :pray:

Thank you @hirnsushi. I have restored images with Magisk, then tried to update as you wrote, without reboot FP4. Here is logcat.txt : logcat.txt - pCloud

Your dsp partitions hash doesn’t match:

07-12 10:16:52.112  1493  1493 E update_engine: [] Unable to open ECC source partition dsp on slot A, file /dev/block/bootdevice/by-name/dsp_a: Success (0)
07-12 10:16:52.113  1493  1493 E update_engine: [] The hash of the source data on disk for this operation doesn't match the expected value. This could mean that the delta update payload was targeted for another version, or that the source partition was modified after it was installed, for example, by mounting a filesystem.
07-12 10:16:52.114  1493  1493 E update_engine: [] Expected:   sha256|hex = 5CDE9B4590A6BD639422B682BC455452E756BAD15435FE74B6806B25E1D14D05
07-12 10:16:52.115  1493  1493 E update_engine: [] Calculated: sha256|hex = 21043D76E83BF63A6A31B44CE65227675732AFB469BE5BBDB07CCF0453B62EAA

You need to flash a matching dsp.img, not sure I have that one backed up, I’ll have a look :mag_right:

If anyone reading this didn’t upgrade to the newest release already, now would be a great time to dump some partitions :slightly_smiling_face:

Great! What exactly should we do?

Normally I’d say wait for someone to dump a partition with the correct hash, but I’ve checked every dsp partition / dsp.img I have and all of them, every single one, including the factory images have the SHA256 hash 8b52788ea43f580b6641b78170df42908b5c39b8c23d54b0d749ed37f5931a73.

So either you were on an ancient build before (for which I deleted my backups) or something else is going on here :thinking:
Whatever it is, it’s not directly related to Magisk, that only touches boot.
What Magisk modules did you install, did you run any other scripts with root privileges that could have altered your system?

  • F-droid privileged extension
  • Font Manager
  • Shamiko
  • Systemless Hosts
  • Universal SafetyNet Fix
  • Zygisk - LSPosed

I don’t think so.

This is my second FP4 and I didn’t brick it like I did with the first one. I just rooted it following your instructions and I applied the OTA until now, but following @rar0 instructions in this topic. Present build number is: FP4.FP3W.A.128.20220516

Hmmm hmm :thinking:

LSPosed might play a role here, not sure why it would touch dsp I don’t see any audio module here.
Did you install any additional LSPosed modules?

In any case, I’d first try a reboot to get rid of all the “systemless” changes that might still hang around and start the update again after that.
That also means you’ll have to reroot manually again once (if) that’s successful.

Edit: dsp is not only related to audio… :man_facepalming:

No more succes logcat.txt - pCloud

Yeah, same error…

We could try to figure out what happened on the 25th of June…

07-12 10:16:52.117  1493  1493 W update_engine: [] Device was remounted R/W 1 times. Last remount happened on 2022-06-25 04:31:39.000 UTC.

…when the dsp partition got mounted R/W for some reason, but honestly I’d nuke and pave at this point.
Who knows what else got changed on your system, better to start fresh from a clean slate.

…at 5:31 am…
So it is better to do a fresh install, isn’t it?

I would suggest it, yes :see_no_evil:

This might be fixable or we might chase one edge case after the other, but without a matching dsp.img there’s no use in trying to figure out what caused it.
I’d say perform a fresh install and if you run into that same problem again down the road we’ll have to seriously look at possible causes.

I’ll upload a Magisk patched boot.img in the meantime so you can at least get rerooted faster :slightly_smiling_face:
Edit: FPOS-A.142_magisk_boot.img

Thank you! I’ll do that

Please: where can I download the boot.img of build A.0128?

I’ve uploaded you a patched A.128 one here, there’s a folder with all my previous patched boot.imgs as well and you can always get specific stock kernels on Fairphones kernel page and patch them yourself if necessary.