English

First bootloop, now random crashing and freezing (LineageOS + new camera module)

Hello,
I am currently having severe issues with my Fairphone 2, which render the phone almost unusable and I just cannot fix the problem, no matter what I try.

Recently, about two weeks ago, I installed the new rear camera module instead of the old one that I received my phone with. The installation went completely fine and i did not notice any differences. At that time the phone was running the last version of LineageOS 14.1, from August, as I had not upgraded the OS yet.
Then, last Friday, the phone suddenly shut down and tried to reboot, only to get stuck in the process and continuously showing the boot animation of LineageOS (after the splash screen). At first I tried to wait and see if the phone would start, but even after manually restarting several times the problem did not resolve.
I did not know what to do, so I tried to manually flash the latest version of LineageOS 15.1 (without wiping/factory reset). This worked fine, and I was able to boot the phone normally.

But now, whenever I use the phone, it will freeze, crash or become unresponsive after some time. For example, when opening an app, the screen will become unresponsive. At this point, all I can do is turn off the screen. Then the phone will reboot. This will happen suddenly, without any notice. What is strange is that I was able to use the phone for many hours without this happening, but then it will happen every time I start the phone.

Does anyone know a solution to this issue? I also tried flashing the latest medium.zip, but that still did not work. Thanks in advance

EDIT: I am currently abroad and cannot put in the old camera module again…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.