Firmware upgrade stuck at 99%

What now?

Try to be patient. Don’t background the process or lock the screen. Keep the update process in the foreground. If that works, then FP has to improve their app.

Hello @Samael
If the issue persists, you can try resetting your Fairbuds XL and then try to do the firmware update.
Reset your Fairbuds XL by pressing and holding the joystick button to the right for 5 seconds.

Let me know if that helps :slight_smile:

1 Like


I experience the same problem : once it stuck to 39%, once to 99%, once to 87%, etc … Every time, after waiting one hour, I reset every connection by holding the joystick button to the right for 5 seconds, renew the connection, re-order the updating process …

What’s wrong ?

Not sure, I will communicate this issue with our software team, maybe there is a small bug that needs to be fixed

Do you have the latest version of the app @Gros_rouge ?


Nope, I haven’t notice that. Let’s try again !

Thanks for the advice.

1 Like

@Juan.Bianchi : OK, it worked after updating the app.


Keeping the screen on for the whole process helped, but now ANC works only on the left side. And another issue after the Android app has been updated, it doesn’t want to connect to the headset because the app says that it requires Bluetooth access, but it doesn’t ask for this access and I have no way to accept it.

Reg the BT message/error


Thank you! Your method worked. Unfortunately, further problems appear. It looks as if the app and firmware were written by an internship student. I know because I created such applications many years ago. “Happy path” works, but any secondary functionality causes problems.