Firmware update tip FP2

Before updating your FP2 to the latest release using the updater app, firstly go to Settings -> Display -> Sleep and set the time to 30 minutes. (Default 1 minute).

When the phone goes into sleep mode, the update seems ‘stuck’, setting the sleep time to 30 minutes overcomes this issue.

After the update has been done, set it back to the time you prefer.

Hope this will help someone.



1 Like

Even better: Go to developer options (you’ll have them as soon as you tapped the built number 10 times - in settings > about phone) and tick “stay awake”. Then plug in your phone while updating.

With stay awake the phone will never sleep while plugged in.


I use FP Open OS 16.05.0 and this option ist not available. It’s grey. Is that because of FP Open OS?

You also have to enable developer options (the first toggle in the menu).

They are.

Strange. Maybe it was disabled with an update?
I’m still on 16.04 and for me it works.

No, it wasn’t. I am on 16.05 and it works. Really strange that it is greyed out @Friek. Did you install any app that is able to control your display settings?

1 Like

The first solution I gave, is also working. So why bother if the developers route doesn’t work :innocent: :grin:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.