Fingerprint reader not working after sudden reboot and failed boot process

This problem is solved at least for the time being, but I thought I’d document it here so maybe others with the same problem can try this very simple solution.

Yesterday, after two weeks of working just fine, my wife’s FP3+ suddenly rebooted while she was using it. The boot process failed with strange blue patterns on the screen and the phone ended up in recovery mode with the options “Try again” and “Factory reset”. After selecting “Try again” the phone booted successfully, but the fingerprint reader was no longer recognized. The entries in the settings referring to it were simply missing. Touching it (screen off or lock screen) did nothing at all. Another reboot didn’t help.

I then shut the phone down, removed the battery and the SIM card, and tightened all the screws (some seemd a bit loose, particularly the one next to the fingerprint reader). After turning the phone on again, everything was back to normal and the fingerprint reader now works just as semi-reliably as before. Fingers crossed.


Well, keeping my fingers crossed hasn’t helped. It happened again, like the time before when the phone was cold and was brought inside. Next I’ll try to check the connector of the fingerprint reader, but I don’t have the tools to remove the motherboard yet.

Reading about how long repairs take and that apparently sometimes nothing gets repaired anyway, I’m beginning to regret I bought the phone for my wife…

My situation is similar but not exactly the same, but I had a fix.
My FP3+ suddenly crashed and rebooted by itself while under heavy use.
(Skype video chat lapsed 30 mins with both parties video on, I use bluetooth earphone, phone is plugged in charging, I assume this is heavy use for FP3+… :thinking:)
It rebooted normally but the fingerprint reader stopped working, no response whatsoever. I go into Settings>>Security>>Add a fingerprint, even this didn’t work.
I saw this post, so I tried taking out the battery and waited for 5 mins.
Now everything is working normally!