File transfer using MTP not working (Android 7.1.2)

Transferring files with MTP still works when I connect my old smartphone (HTC, android 4.1.1) but it doesn’t work at all with my FP2 (android 7.1.2). The FP2 is not recognised by the computer (Ubuntu 20.04.2).
With my HTC I can access the internal storage:

ls -alh /run/user/1000/gvfs/‘mtp:host=HTC_Android_Phone_SH2BPLY00420’
total 0
dr-x------ 1 sclaes sclaes 0 Jan 1 1970 .
dr-x------ 3 sclaes sclaes 0 Jan 29 13:17 …
drwx------ 1 sclaes sclaes 0 Jan 1 1970 ‘Internal storage’

With my FP2 this does not work:

ls -alh /run/user/1000/gvfs
total 0
dr-x------ 2 sclaes sclaes 0 Jan 29 13:17 .
drwx------ 14 sclaes sclaes 400 Jan 29 13:47 … is not helpfull. Is it android 10 specific?

Why does it not work with android 7.1.2? (android 8.1.0 seems to work).

Any suggestions?

Welcome to the community forum.

I have no immediate additional idea if you have worked your way through the support article already, it’s not Android 10 specific.
Perhaps the search has something? … Search results for 'linux mtp' - Fairphone Community Forum

The support article is supposed to be FP2 specific but my FP2 (android 7.1.2, build number 19.11.2) has no usb c connector and there is no ‘usb charging this device’.

With a cable and USB port which work for another device?
There’s no notification with this message if you pull down the notifications from the top of the home screen?

No ‘connected devices’ in settings, no ‘usb charging this device’ when pulling down the notifications from the top of the home screen, so I cannot enable ‘transfer files’.

It works with my Wiko smartphone (android 8.1.0), but not with my FP2.

Perhaps I should update my FP2 to android 9. I will try this later (when the battery is fully charged).

You can of course try to upgrade to fix some hickup in the OS, apart from that the part with the notification and selecting the USB connection mode works the same since Android 6.

Did the data connection with the Fairphone 2 work before?
Could the port be damaged or could there be dirt in the port?
Does the phone charge?

Did the data connection work before? I’m not sure.

I used to transfer pictures with the sd card (open camera saving to sd card instead to internal storage.) But a while ago the sd card stopped working (I lost some pictures) and I had to use internal storage until I got a new sd card. I copied the pictures that I took in the meanwhile but date and time are not preserved (an android 7 bug?), so that’s why I tried to transfer the pictures with an usb cable. Only to find out it doesn’t work.

When I connect my phone to my computer and I swipe down I see
Android System . Charging this device via USB

But when I connect my phone to my computer with a 2 threaded cable (only fit for charging) I don’t get this message.
Which make me wondering if you use a 2 threaded charging cable instead of a 4 threaded charging and DATA cable?

1 Like

There is no problem with the usb cable but there is an intermittent problem with the micro-B usb connector of the FP2. Not sure if this repairable.

Anyway thanks a lot for your support.

It is not a software problem after all, it is a hardware problem.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.