English

FF3 and lineageOS

Sorry, I am totally new here. Got my FF3, wanted to install LineageOS, found a great looking guide how to do it and failed.
I followed this guide:

Step 4 I followed through but could not get the fastboot oem unlock.
FAILED (remote: oem unlock is not allowed)` or command not found
(fastboot was found, but not what came afterwards)

But there was a hint in the internet how to do this without OEM Unlock.
That was step 4 in chapter 4.
And then I failed.
Step 5 I did not really get.
I could see the bootloader is unlocked.
So I thought I chose the correct line and continued with chapter 5.
I downloaded the mentioned files.
But step 3 Boot your FP3 into the bootloader I did not understand what to do. I thought I was in bootloader.
And from here nothing works anymore.
I get a screen on the phone in small small fonts telling me that it cant load android system
Try again or factory reset.
All commands I issue in the terminal fail.
adb devices does not recognize the device.
The list is empty.
I am lost.
Please help.

Ok, seems I have proceeded to TWR .
Now at Step 6 it tells me to navigate to Factory reset → Format data/factory reset but I cant find this in TWR. It shows me Install and Wipe and Backup Buttons etc.
It seems to be under Wipe. But then what should I do? Format data or swipe to factory reset.
I guess format data.
Done.
And now? Reboot system or Back?
I guess back. But now I cant find
Apply update → Apply from ADB
anywhere.
I am a bit scared if I reboot that I cannot connect at all anymore. On the other hand I see that a lot of data seems to be still there.
Please help.

I was in a jolly mood so I tried a few things.
I think I ended up in the Install and then the ADB Sideload. And when there I typed adb sideload lineageos… and it installed.
Maybe these hints here can be used to update the otherwise excellent doc?

All these tips (Enable OEM Unlock in the dev options for fastboot oem unlock to work; in case you use TWRP use ADB Sideload) are already in the guide you mentioned in the first post, so you might not have seen them.

Did you follow thoroughly step 3 about enabling OEM Unlock?

I think your mistake is that you followed the LOS Recovery and not the ones of TWRP.
image
It is the same step but it depends on the recovery you are using. You are right it is perhaps not that clear, I’ll solve this.

2 Likes

thanks for the quick reply. It was late and I may have overlooked something.
finally I got it installed, somehow.
Yes I got the OEM unlocked and it told me in red that the bootloader is unlocked.

1 Like

Well then… it was fine wasn’t it?

Hi Alex,
I checked what I did yesterday.
I followed this link:

and here is where i ran into problems.
Chapter 4:

  1. Now, enter fastboot oem unlock
    This didnt work… I got an error. I searched the community and found something with 8901_unlock or so. Didnt help. I search the internet and it offered another solution. which worked. When I finished and entered what fastboot oem unlock I got the same message as from the other solution. Done.
  2. Next, you have to accept the unlocking on your phone.
    Navigate with Volume + / Volume - buttons and press the Power button to proceed with the unlocking.
    I did not get this. I saw some lines, the first in red, the last in red indication the bootloader is unlocked. When I pressed the volume buttons it said: Start, Restore, Reboot, and I had no clue which one to use.
    3.This step will unlock the bootloader and wipe all your data!*
    I had no clue what is wanted here.

5. Installing LineageOS

  • Boot your FP3 into the bootloader
    which comment? adb or fastboot. I am not a techie. And old, so my memory is poor
  • Connect your FP3 to your computer
    I wondered. Shall it be disconnected before this. Is this a must?
  • Open Minimal ADB and Fastboot and enter the command fastboot boot RECOVERY-FILENAME.img
    Did that and it failed.
    Obviously because of what happened before in chapter 4.

That means you didn’t need step 4 anymore, as the point of the step 4 was to unlock the bootloader. So if you had managed to unlock it otherwise you could pass on to step 5.

Bootloader=Fastboot

No, just in case it was disconnected before.

Did you really enter fastboot boot RECOVERY-FILENAME.img? RECOVERY-FILENAME should be adapted to the actual name of the file you downloaded.

I am seriously stupid but no, I did not use RECOVERY… The point was, that adb devices and other commands told me no device connected.

Sure you were supposed to be in fastboot mode, so did fastboot devices output anything?

Anyway, it’s solved and you managed in any case.

Indeed
and I am happy and proud about it :slight_smile:
Thanks for your efforts in the manual and for the support here in the community.
May I ask: If I want to install another custom rom such as lineageos for micro_g or /e/ would I follow the same process til the bootloader or are there any descriptions not from a stock android but from another custom rom?
I would suppose the critical part is getting to the bootloader and to the twr.

Same process, except if didn’t relock bootloader you don’t have to unlock it again, so you can go directly to step 5.

For /e/ you find an installation manual here Install /e/ on a Fairphone FP3/3+ - “FP3”
If you don’t need to unlock the bootloader because it is still open you must wipe the data partition instead, because that happens when you unlock the bootloader.

Thanks a lot.
So far I am surprisingly happy with lineage os