English

Fast draining battery, can't run ADB to make BetterBatteryStats work

Hello knowledgeable people!
I’ve been having problems with my battery draining very fast. Today it was fully charged at 6 a.m., and entirely drained by 09:30 a.m. The battery monitor looked like this:


The CPU has also been getting very hot.
So I looked on this great forum, and got the advice to install Better Battery Stats. I did that, but it didn’t work. My phone isn’t rooted (I’m not a real computer expert and just wanted an easily usable phone!) When I open BetterBatteryStats, I get this message:

I was able to enable Developer Options for USB debugging, and to install the ADB drivers (from https://forum.xda-developers.com/showthread.php?t=2588979). However, when I try to check it’s working by using “adb devices” at the command prompt, I get the response “List of devices attached”, and then nothing underneath. When I type “adb -d shell pm grant com.asksven.betterbatterystats android.permission.BATTERY_STATS”, it says “error: device not found”. I tried using the ADB driver installer recommended in this forum, and I got the result below:

Note that it appears to recognise my FP2, but without a name, and it says “ADB Driver already installed”. I tried updating the drivers using Device Manager, but I can’t get my FP2 to show up as an Android device. It shows up as below:

I don’t know what to do now - can anyone please help me? One thing I’m not sure about is if I’m doing the Command Prompt right. I’m just using the Windows Command Prompt, but I don’t know if I have to give the command from a certain place. I’ve tried doing it from within the C:\adb folder, but that didn’t work. According to https://www.howtogeek.com/125769/how-to-install-and-use-abd-the-android-debug-bridge-utility/, “you have to navigate to ADB’s folder and open a Command Prompt there whenever you want to use it” - but I’m not sure what that means.

Now I’m stuck! Any help would be much appreciated! Thanks :slight_smile:

To be 100% sure: did you just enable the developer options? Or once they were enabled, also the USB debugging inside the new dev options menu?

If it’s the latter I’d say you did everything correctly and the phone should appear in the list of the devices.

Not sure if windows needs a reboot after the installation of the ADB drivers. The other things I’d try are to change the USB cable and/or USB port on your PC.

I would suppose battery lifetime has been reached. After one and a half year I have had these symptoms - heavy battery drain but phone has been idle … I have replaced the battery with success …

Thanks. Yes, USB debugging is enabled - and you can tell my phone thinks it’s working when it’s plugged in, because I have the little bug icon at the top of the second screenshot.

I’ve tried rebooting, using a different cable and a different USB port. It doesn’t make any difference.

I note that in the Developer options, under “Select debug app” it says “no debug application set”. Does this matter?

Any other ideas welcome! Thanks.

Thanks. I hope it’s not battery lifetime - my phone is only 6 months old (Fairphone kindly replaced the last one after it got stuck in a boot loop of death).

Another wild guess: try to run the command prompt as administrator if you haven’t yet.

Thanks - good idea but that doesn’t seem to make any difference.
One new idea though: I realised that my phone never asked me for permission to let my computer access it. (I’m not sure if that’s necessary in my version of Android - 6.0.1?) So I tried pressing “Revoke USB debugging authorisations”, and nothing is different. So I wonder if my computer isn’t properly authorised in my phone? But I don’t know how to do that. I don’t get anything like this screen (from https://www.howtogeek.com/129728/how-to-access-the-developer-options-menu-and-enable-usb-debugging-on-android-4.2/)


Thanks again for any advice!

Hello, I don’t know much about your battery problems, but for the ADB thing, if I remember well you can :

  1. Press Shift
  2. Right-click on the adb folder
  3. Select ‘Open command prompt here’ (it appears in the menu)

Then it should work. You can then call your device by typing adb devices, and the screen you just posted should appear. Then you can autorise USB debugging from your computer. If it donesn’t work, my bad, :frowning_face:. You can also make a shortcut on your Desktop and open the command prompt here as you normally would :

In File Explorer, press and hold the Shift key, then right click or press and hold on a folder or drive that you want to open the command prompt at that location for, and click/tap on Open Command Prompt Here option. There is a simplier way I know. Find cmd.exe in start menu and send it to Desktop as shortcut.

The thing with Windows, as it seems, is that you can only execute ADB where the executable is. And then it is much simpler to have the images that you want to flash in the same folder as ADB, so that you don’t have to navigate whithin the prompt to the right place - it’s easy to do with Linux and other UNIX-like, I’m lost with the Windows method.

Thanks. I didn’t have the option to Open command prompt (I’m on Windows 10, if that makes a difference) but I could open a PowerShell - is that the same thing? Anyway, I did that and got the same response:

If I type “adb devices” again, it just says “list of devices attached” (i.e. it doesn’t repeat the 2 “* daemon” lines.

I note that if I just type “adb”, it gives me a list of command prompt options, but none of them seem like an obvious solution. It seems to me that my problem is that my phone isn’t allowing my computer to connect to it in the right way (it’s not asking for permission to allow the computer to connect), and that’s what I need to fix.

It seems that it makes a difference. Maybe Windows did release a new shell with Windows 10 (I don’t know, I use Linux). There’s a last thing you could try : when you plug your phone to the computer, you get a message saying that USB debugging is activated. When you unlock your screen, the dropdown menu you can swipe from the top on the screen shows you two notifications : one that USB debugging is activated, one to say that your phone is currently charging over USB, but you can select the note to see the other options. You can choose other things, like File transfer. If you choose this and call adb, does it do the trick ?

I had similar battery problems with my FP2. I am a totally non-tec person and I followed the forum battery reset advice. My two year old battery is now as good as new. I also treat it gently, only ever charge it from 15% up to full, never part charge it, and I turn the phone off at night. This means the alarm does not work but that is a small price to pay for a phone which works well.

1 Like

My battery has also been draining really quickly - at first I thought it was because I’ve been living in extremely hot Berlin, but it is a couple of years old so it is probably age. Could someone talk me through or show me where to find battery reset advice?

Hello, you can find the guide to Fairphone’s batteries here. If you want to reset your battery, you can do it following this guide.

I hope you will find the solution here ! Good luck :slight_smile:

1 Like

You’re very kind to your phone! I might have to try that if I can’t identify an app (or apps) that is causing my battery to drain so fast.

Thanks for your patient advice! This didn’t make any difference, but I did manage to fix the problem. I deleted my original install of adb (which was v1.3 from here: https://forum.xda-developers.com/showthread.php?t=2588979) and instead installed the ZIP file from here: https://www.xda-developers.com/install-adb-windows-macos-linux/. When I ran a PowerShell prompt (which seems to work as well as command prompt), it first gave me an error message, saying it didn’t recognise adb - but it prompted me to use “.\adb” instead. That worked fine, and then my phone did prompt me to accept USB debugging from my computer.

Thanks for all your help!

2 Likes

You’re welcome ! Great to see that you could solve your problem :slight_smile: You say that you installed an other version of adb, was it more recent ? If yes, did your old version of adb never tell you that it could be updated ? I don’t know how it works on Windows, but on Linux distros where adb and fastboot are provided as packages you can download them and they are regularly updated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.