Fairphone1 display repair

Successfully repaired FP 1 display this afternoon with
very helpful ifixit tutorial http://tinyurl.com/Fairphone-display-repair & reassuring repair companions – great repair support by #RestartParty @arcolatheatre hosted by @SustainHackney #foehackney
The Fairphone B-stock displays are fine and great value beyond #cosmeticstandardshttp://shop.fairphone.com/spareparts/b-stock.html. Thanks!

(new display repair in progress)

(another successful Fairphone display repair #RepairParty)

(screenshot of B-stock display)


This is great! Thank you for sharing the pictures! :slight_smile:

1 Like

I followed all the steps very carefully and now my phone cannot be switched on again. I assembled and reassembled carefully four times now. It was a real hassle to get the screen and the tools and took months and a lot of money.
The response on the question on my broken screen was incomplete and also took months in the first place. It is such a shame.
Does anyone know what to do now? Nothing weird happened during my assembling and reassembling and I really tried everything to get it working again :((
When I connect it to the charger, it does charge.

Dear Judith,

Welcome to the forum. I’m sad to hear that your phone does not work anymore. Hopefully we will find a solution. In order to help you we need some more details.

What steps did you follow? Do you have a link of the guide?

What exactly are you trying and how exactly does the error manifest? Is there an error message, and if yes, what does it read? Have you tried holding the power button for a longer time?

What response do you mean? Are you talking about another thread in this community forum? Or did you contact Fairphone with a support request?

Please list everything you tried. Maybe someone knows yet another approach that you could try.

How can you tell that it charges? Does it show the charging battery on the display?

At this point I can only guess. One guess is that something might be wrong with the power button. Apparently the phone turns on for charging when you connect a power supply. What I understand, however, is that it does not turn on when you press the power button. There are many ways for something to go wrong when disassembling and reassembling the entire phone.

With some more information we might be able to drill down to the problem.

Hello! To repair the screen, I must send my fairphone? or the Fairphone’s team send me a new screen and I have to repair it?

Thank you for your quick reply!

I followed http://shop.fairphone.com/spareparts/fp1-spareparts/display.html at first and then the much more extensive and better visible https://www.ifixit.com/Guide/Fairphone+Display+Assembly+Replacement/20605 (shame it’s not easy to find via the first obvious link)

The problem is indeed the power button. It does not switch on at all, so there is no error message. I tried to switch it on via the power button after assembling and reassembling via the manual a couple of times. I also tried holding it on for a long time and just pinching on the power button without the black button plus rubber itself.
I had no problems in the disassembly, except that I lost one screw, there was no 1.6mm screw
and the rear-facing camera fell off the motherboard (I didn’t do anything weird and followed the manual, I don’t know why) and I have to hold it together in assembling. Both seem to be common phenomena by the ifixit manual. And it shouldn’t affect the power? After assembly the midframe and screen don’t fit together perfectly anymore, but the difference is tiny and I do not know why. I don’t want to worsen that now by more attempts to follow the manual.
The red/green light on the right bottom is the only thing, which tells me it charges when I connect it to a charger.
I do not know what else to try or what to do now.

About the response when I first contacted the support about my screen:
I asked what I should do after my screen broke, they did not link me to the forum or told me about the option to order spare parts. Instead they told me about a ~170Euro repair which would take two weeks and send me a form. I postponed fixing the screen therefore, because I have to say the phone still worked fine after fixing it with a mere tesa stripe (can’t have an influence on this failure too). Plus I assumed if the zendesc told me so, there are no other options. I saw no reason to search the website for more options. Then I heard from a friend about this option and finally searched via the forum etc. I told the support about this, too. It was unclear how many tools you really needed (not even available on peerby) and how risky it actually was. So it took me even more time and money to get the tools. Now my phone fails to work completely. That is why I am frustrated on how this is handled, even though I really want to support the idea of fairphone and self-repair in general.

It could be that this screw connected two metal parts, which are now separate and can’t transmit a signal, or something similar. Can you try to take a 1.6mm from another spot and put it where it is missing?

No there is a 1.6mm screw described in the manual, which a lot of people seem to miss in their fairphone, it has never been there.
Apart from that I lost on of the nine 3.9mm screws, every position I tried it does not make it work. Before I senselessly go to the shop and spend even more money on this now, could somebody please tell me if that could really be the problem? I mean it is technically known whether all of the screws also transmit signals here, right?