Fairphone Updater: No manual "check for updates" options

The problem: The Fairphone Updater seems to only check for updates when the phone is rebooted. Because of the “clock bug” I am not rebooting my phone and I was waiting for the OpenOS 16.09 update notification to show up - negative. Only after a reboot I was informed that an update is available.
Feature Request: A simple “check for updates” button in the app that allows exactly that: Manually checking for FP or FP OpenOS updates.

3 Likes

I believe the updater checks for updates when the connectivity changes (mobile/wifi).
At least in the past it was like that and you’d also get a notification saying “downloading update” every time, so I restricted the updaters background behavior with Autostarts.
Since then I get informed about updates via the forum, but as soon as I open the updater app I see the update,

Could it be you simply had no internet connection at that time?

1 Like

Even if I don’t run FP Open OS I can approve that there’s no manual option to check for updates but would be fine with having one.
Iirc the update from FP OS 1.7.0 -> 1.7.1 was shown first time on my phone on the train after passing a tunnel, which would support @paulakreuzer 's thesis.
In contrast to Paul’s description (if I didn"t get it wrong) I had to start the download manually - which is exactly the way I prefer it.

So I can’t tell if this is a bug, but I would in any case support a feature request to influence the Updater’s behaviour (e.g. manually, daily, weekly, on network change - or switch off completely at certain times). However I would personally rate some other bugs & features with higher priority.

1 Like

I do actually change the connection status quite often, because for different reasons I do not want to have mobile data and/or WiFi enabled all the time. So basically nothing happened until I rebooted - although WiFi and mobile data have been switched a couple of times over the days since the update was released. This means: BUG

I also think the updater checks more often than just on reboot for updates. I think killing it and reopening should do the trick either.

I don’t know if it’s there on FPOOS, but on FPOS (with GMS), there is a “developer mode”, which can be activated by tapping the version (“Fairphone OS 1.7.1” in my case) several times. When you enter http://ota.fairphone.com/, it sends a request every time you’re hitting OK.

3 Likes

I can confirm that this also works on FPOOS (16.09).

2 Likes

Developer mode works on 16.09 too, but I think a manual update check should be visible and not hidden like an easteregg in a developer mode.

Or there is an error on your phone.
Do you use any apps that could restrict the updater app? Permission Manager, Firewall, Ad-Blocker?[quote=“retsifp, post:5, topic:22517”]
there is a “developer mode”
[/quote]

I think that’s just for beta testers, so if you don’t want to update to beta versions it’s not very helpful is it? On the other hand on FP Open OS there are no beta versions, so it’ll probably work fine then.

Just checked on my FP OS 1.7.1 non-beta device: I can also access the “developer mode” like @retsifp described. I didn’t check the network traffic after hitting “OK”, however.
So even if it might not really make sense generally for non-beta users it mght help on @M_Dammer 's issue:

  • If it works as a workaround.
  • If it doesn’t work as option to verify the bug.

The “dev”-mode was there ever since the first public FPOS-Version.
[ I’m pretty sure about this, because the FP-Update-Request, which I sniffed in this time was http://ota.fairphone.com/FP2/updater.zip?&ota_v_n=<version>&beta=0&dev=0, the dev=0 means that the developer mode is off. For some versions now, the updater uses https, so the developer-mode is pretty useful for sniffing update-requests :wink: ]

@M_Dammer:
I agree with you, that this is only a workaround, but I also think that there is no bug. I think the updater on FPOOS and FPOS are pretty much the same code, and I just wireshark'ed the traffic of my phone:
I didn’t find, that the phone automatically checked for an update on connecting to my WLAN (could be a timer, which checks only once in x hours or so…), but as soon as I opened the Updater, I saw encrypted traffic to ota.fairphone.com (which, btw, CNAMEs to ba.fairphone.com).
Please note the updater was closed before, so just tap on the square and swipe it to one side, if it was open before.

Edit: Another Idea: You wrote about the clock bug, but you set your time correct?! If that isn’t the case, any HTTPS-Connection will fail, so the update-request will always fail unless you manually set it to http. You can easily check this by visiting any encrypted website with your browser (e.g. https://google.com). If there is no error, everything is fine.

1 Like