Fairphone OS 19.11.2 update. Upgrade error: Unable to find partition for path '/system'

Thanks so much but you bet that this is pretty much the first thing that I had tried. As the phone isn’t recognized by the PC (same issue as the person that created this thread) that guideline is of no use to me unfortunately. I tried to install the OS zip file directly from a micro-SD but without success yet (as reported). But I am hopeful to solve this by manually installing another version of TWRP. So if I am successful maybe we can augment this great guideline you compiled with a scenario where fastboot doesn’t work (since the device is not recognized).

Which file exactly?

I’m always in favour of whatever works, but since fastboot is the “last line of defense” when things go wrong, there has to be a way to get this to work.

Are you certain the phone is booted in Fastboot Mode when you run fastboot commands?

Did you use the fastboot command from the current Android SDK platform tools, like the guide suggests, or did you use the fastboot command your Linux distribution offers?
Perhaps there’s some incompatibility with a fastboot command version. What does fastboot --version say in either case?
Might even be worth a try to use the fastboot command which is included in the Fairphone OS install file.


Thanks for being persistent, it gives some confidence that fastboot really should work so here the details of my attempt.

I recognize the fastboot mode by the blinking blue led and the fairphone logo displayed. I entered it both, from the TWRP (there is a reboot option that brings the phone directly into the fastboot mode) as well as by pressing volume - .

I used all fastboot that I found available. First the one that comes with the Linux repo [fastboot version 1:8.1.0+r23-5]. Then the one in the Fairphone OS zip archive (though accessed via flash-for-unix.sh, I can’t run fastboot directly, I get an “Exec format error”, somehow it doesn’t seem a suitable binary file to execute directly, thus I cannot inquire for the version either, but it is from fp2-gms-19.11.2-manual.zip) and the one downloaded Android SDK Platform Tools per the suggestion of the guideline [fastboot version 30.0.5-6877874]

None of these have found the phone. I did test these with twrp-3.3.0-0-FP2. I am wondering now whether the TWRP version matters? Does TWRP interfere in any way with fastboot or are these two independent things?

(The cable was always working thus far and I can still verify that it charges the phone)

Regarding the attempt of installing different TWRP versions: Installing TWRP 3.3.0-0-FP2 did not solve the “zip signature verification” problem. It did remove the “unable to find partition for path ‘/system’” however. So it really seems that that is not the problem and one can safely ignore it. So also this route is still unsuccessful.

– Correction: I actually get “Invalid zip file format” not anymore “zip signature verification failed” since I installed the different TWRP. Apologies for not checking carefully. I did check the md5 and it is correct on the SD-card. Will do some more research on this error.

Good mention. Did the cable work for data connections before? There are cables out there which are only wired for charging, not for data.

TWRP is recovery mode.
Fastboot Mode is this:

The fastboot command only works in Fastboot Mode. It doesn’t work when TWRP or any other recovery is booted.
So the question still stands:

And this, too, concerning the OS file you try to install with TWRP:

If it’s fp2-gms-19.11.2-manual.zip, this is not made for installing with TWRP and will not work in any TWRP version.


Thanks for the quick reply! Just to be sure: I definitely boot into Fastboot mode and that’s when I test the fastboot shell command. As I said, I know how to identify it. I was just asking about TWRP to be sure that the version of TWRP I have flashed on my phone does not somehow interfere with fastboot. And I take from your reply that it doesn’t matter which TWRP I have installed since they are two fundamentally different modes and don’t “talk” to one another.

Re cable: I have performed file transfer with it numerous times and also very recently.

Thanks so much for the last point re fp2-gms-19.11.2-manual.zip that it is not suited to be installed with TWRP. I had followed this guide but it seems that a zip file must have a certain structure as I found mentioned here. In the mentioned guide I am referred to use the zip file from here. I then also tried the versions OS 18.04.1 and OS 18.09.2 found here. I guess needless to say that I get the exact same issue.
Do you know where I can find a zip file suited for installation via TWRP? I am skimming the net but not sure what to search for.

Solved solved solved!! Just to be sure I borrowed another USB cable from my neighbor and now it is recognized! Oh my! No idea why it didn’t work with the other one since it always worked (I had even changed the FP USB module because that had some issues, sometimes a little loose contact so that it wouldn’t even charge). Anyhow, thanks so much for the support and bearing with me!!!


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.