Fairphone OS 19.11.2 update. Upgrade error: Unable to find partition for path '/system'

Hello. I have a Fairphone 2 and yesterday I tried updating from Fairphone OS 19.08.1 to Fairphone OS 19.11.2. I ended up on the Team Win Recovery Project with an “unable to find partition for path system” error.

Unfortunately I didn’t think of googling this error first, so in succession I tried the following:

  1. Manually updating from my PC (Windows). This didn’t work as, prior to this, I’ve been having lots of issues with getting my PC to recognize my fairphone using a USB cable.

  2. I downloaded the manual update to my SD card and tried to install from there using TWRP. I get the following error: "zip signature verification failed! Error installing zip file ‘/external_sd/fp2-gms-19.11.2-manual.zip’

  3. At this point I successfully managed to create a backup of all my data to save to the SD card, so I tried doing a wipe (Data, Cache and Dalvik) in the hope it would do a factory reset on the phone. If the installation zip was on cache, as other topics on the forum suggest to try, it was wiped at this point.

Needless to say, this didn’t work either, and I still get the ‘Unable to find partition for path ‘/system’’ error.

Is there anything else I could try at this point?

You have to disable zip signature verification for this, it won’t work otherwise.

Try to mount system partition in TWRP (Mount→Check System).

1 Like

Hi! I have disabled zip signature verification both in Settings, and when I go to install the zip from Install. The log still shows a zip signature verification error, though.

I can only see “Mount system partition read-only” on Mount and it’s checked, suggesting it is already mounted. At any rate, these are the options on Mount:

Select Partitions to Mount:
Cache (checked)
Data (checked)
Modem (not checked)
Persist (not checked)
Micro SDCard (checked)
USB OTG (not checked)
Mount system partition read-only (checked)

And then two buttons: Mount USB Storage and Select Storage. System appears in neither of these.

Are you under Fairphone OS or Fairphone Open? Does that mean you manually installed TWRP? Which version do you have?

I believe that’s the problem. You’re in read-only.

1 Like

It was Fairphone OS. I didn’t manually install TWRP, but it also wasn’t installed when I purchased my phone in 2016. I believe it was included in one of the updates.

Also, as of five minutes ago, TWRP no longer loads. I believe I am in bootloader, as the screen just says FAIRPHONE, powered by Android, and the charging light is blue.

Is it possible to send the phone back to Fairphone to be reformatted, do you know? I think I’ve reached the end of my rope here.

FPOS didn’t come with TWRP preinstalled AFAIK. Only FPOOS did.

You are. Try to download the latest TWRP release and flash it from fastboot by running fastboot flash recovery [name of the file].img and try a manual reinstallation: :gb: :de: :pencil2: Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall

I believe you could but it may be costly. Perhaps there is a #fairphoneangel in your vicinity that might be able to help you?

1 Like

Good news: I can access TWRP by pressing volume up and the power button at the same time.

The bad news are that I can’t do a manual installation from PC, as I noted on the original post. My PC simply refuses to recognize my phone, hasn’t done so for ages. I thought it was a bottom module issue for a while, but I replaced that module in July and the issue persisted.

I also can’t leave read only mode. I googled around, but it won’t let me uncheck the read-only option on Mount. I also know I didn’t install TWRP myself, so I’m not sure how to fix the read-only issue. It appears I’ve reached a stalemate - I can’t manually install from PC as my PC doesn’t recognize the device, and I can’t install from TWRP as I’m on read-only mode.

My location is Madrid, Spain. If indeed there is a #fairphoneangel around. Edit: just checked the Fairphone Angel topic and searched for Madrid. We’re out of angels in the area. :sweat_smile:

1 Like

Sure, I didn’t think about telling you, I had understood even this combination didn’t work :sweat_smile:

Maybe the cable? Did you try another one?
Otherwise perhaps a problem with your fastboot? Did you try reinstalling the Android SDK Platform Tools, and trying again?
I suppose you don’t have access to another PC…

Do you mean tapping on it really just doesn’t do anything? Strange… I believe reinstalling TWRP would help, but you need a working PC for this.


Well… there was and is an angel in Madrid, but he paused the heaven, so indeed consider there isn’t any.

1 Like

I tried with another cable, to the same results. I don’t have another PC available at the moment, but I will try with another PC and report back.

I have gotten in touch with Fairphone Support (if only so I could get a quote for how much the repair would cost), but it really does appear that they’re swamped with Fairphone 3 support requests. I have yet to get an answer from them.

Thanks so much for all your help today!

1 Like

Update: I’m on another PC, and have tried with 4 different cables.

There was a promising moment where the PC indicated an Android device had been connected to the PC, but I clicked away from that screen thinking I could now flash the Fairphone update. It was not to be, and I haven’t been able to get this new PC (and the several cables) to recognize the device again.

I downloaded the Android SDK Platform Tools, but it doesn’t list any device when I input the command fastboot devices. (It doesn’t seem that I have to do anything beyond run cmd as admin and type fastboot devices from platform-tools.)

I have no idea why my phone can’t be recognized by PCs… It’s been an ongoing issue and I ended up buying an OTG with a card reader so I could move data through the SD card. But obviously, that doesn’t work when TWRP is in read-only.


as the fastboot command does not find any devices on your system, you may also want to check these two things (if you haven’t already done so):

  • For the fastboot command to work, the device needs to be in “Bootloader” mode. This is the mode you described above (Fairphone logo, blue blinking LED). fastboot will not work, if you have already booted into the TeamWin Recovery. If you have booted into the recovery you can use the Menu of the Recovery-System to reboot the device into the bootloader.
  • I have never used fastboot on Windows , but I remember that in the past this required the user to install a special USB driver. I am not sure if this is still required, maybe some other users have experience with that. If you want to see how these installation looks for the Google devices, take a look at https://developer.android.com/studio/run/oem-usb

For me, fastboot always worked well in the past, so you might not be far off.



Did you receive a message on the FP2 display to grant access from the PC with a certain MAC address? Google for “revoke USB debugging authorizations”.

This is for ADB accessing the phone, it should not be necessary for the fastboot command to work in Fastboot Mode.


But to get fastboot working, you need ADB…
Edit: OK, lesson learned:

You can also boot the phone into Fastboot Mode by simply keeping Volume - pressed while rebooting or starting it :wink: .


Hi all, I am experiencing the exact same problem. I have tried those several points that Aitziber tried without success before stumbling over this post. My phone won’t be recognized either by my laptop. I tried another PC as well. They all would run on Linux so I was wondering whether that could be the cause for the phone not getting recognized but it seems Aitziber tested on a Windows system too… (though I never even got that far to see anything recognized as Aitziber did) really stuck with this issue and my phone is out of order for 4 days now already - ever since I attempted to install the latest update. There must be a solution, it would be incredibly frustrating if an update was to essentially trash a phone.
I really feel this is the end of the rope since I tried to wipe pretty much everything, tried to install an OS by hand by putting it on a micro-sd card then copying it to the internal memory and tried installing it - but there I get the message: “zip signature verification failed”. Thanks for any hints on what to try further!

Since you wiped pretty much everything, please follow this guide, don’t skip any steps, and report at which point you run into a problem …


You get this from TWRP?
You will have to disable zip signature verification when flashing some zip files (e.g for a custom ROM). See an explanation here.

1 Like

Thank you for the quick reply!! But unfortunately I had found that already in the forums… the checkboxes, both in the install menu as well as the general settings in TWRP, are unchecked. So in theory it shouldn’t perform a zip signature verification, yet that is the error message I get in TWRP. I have found that others have this problem too. I am trying to install a different TWRP version hoping that will fix the problem. If so I’ll report here of course.

1 Like