Fairphone OS 17.10.1 is now available

Does your display behave normally? You can test it via Maintenance -> Checkup -> Drawing. Can you draw everywhere on the display?

Hi @Phoux ,

This sounds like a hardware defect… Please test the display with the Checkup tool and contact our Support team if necessary.

1 Like

I tried with my old shattered Display (still working properly before the update) and with my new Display (that I received just recently). When pulling down the menu on the top it still says “no new Messages” ("Kein neuen Benachrichtigungen). Also, when trying to use the the circle or the square on the bottom, the Display reacts by enlighting the square/circle but it doesn’t react any further.
I can draw everywhere on the Display - but can’t get out of the drawing mode anymore.
Today I cleaned the contacts of the Display module and the contacts of the phone, I also removed the battery for about 30 minutes but all this didn’t help at all.

1 Like

hi, finally problem solved: my administration was so kind to grant me an exception for my device! :slight_smile:


I admittedly was a bit reluctant first to install this update, after reading of the problems in this thread.
But it worked just fine. No problems. All buttons still functioning as they are meant to be.

Great work.


Thanks @BertG for reporting back. Same as you, I was a bit in doubt about updating. So thanks for trying before me. :smile:
Update also worked fine for me.

Congrats & big thanks to the Fairphone team! Iirc this was the quickest monthly security update for FP2 ever. Great job, guys!


Hi Rick,

as suggested I checked the display with the checkup tool. But like Claudida the display seems to be ok. My phone shows the same behavior as described by Claudida.

I am not sure if this is a hardware defect. As display seems to respond properly.



Due to the battery drain I often check the wifi status including the Wifi Scanning option (which sometimes becomes re-enabled) after the new update if I try to search in settings for ‘scanning’ I get no results, has this been removed?

Do you happen to mean:


  • Developer options
    • Always allow Wi-Fi Roam Scans



  • Wi-Fi
    • (Settings i.e. three dots in top right corner)
      • Advanced
        • Keep Wi-Fi on during sleep

Hi, it’s the settings option mentioned on step 13 on this page

As I didn’t have the 3 dot menu on the location screen I just use the setting search feature to search for ‘scanning’ to get to the same screen. Or rather, I ‘used’ to use the search option.

Well, I don’t have them as well and I have turned location off generally, as I don’t want Google to track me. Therefore I am a bit reluctant to turn it on just for testing purposes.
But searching for “scanning” I get three results.
I really have no idea, why these settings are missing on your phone.
I suspect, you use location services, otherwise scanning is off anyhow.

Well, hopefully someone with more insight into the technical parts of Android can help you here.

it wasn’t that the option was removed, it was that the settings search function was broken. I just cleared the data of the settings app and I can find the scanning option again.


Hey, congrats!!
Glad for you.
Just odd, that kind of malfunction happened in the first place.

Hello @anon12454812, Are you aware of https://www.krackattacks.com/ ? The story is out there for quite a while already but I’m not sure if my phone is prone to this attack (haven’t tested what was displayed in https://youtu.be/Oh4WURZoR98)

Had a problem using the updater due to a stuck “TeamWin” screen after restart, but used method 2 https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-installation-instructions.html . I hope next time I can use the Updater again… Or do I need some fix on the Recovery Image?

1 Like

Yes Fairphone is aware of this, as @Douwe stated:


Hi @OmeLuuk,

We are working to get this fixed ASAP; our intention is to release a fix earlier than our standard monthly patch - stay tuned!



Anyone any idea on the other issue? This update also requires a manual install due to this screen:

It will not pass this point before my battery runs flat or the phone shuts down due to the raised temperature.

I suppose it is working hard in a loop, will I be able to read logfiles, or debug this situation with the updater?

Could be the same or similar issue as the one reported here for another version of TWRP - depends on whether you’re running adopted storage now, but were running the other form of storage before that:

Fairphone OS 17.10.2 that fixes the KRACK vulnerabilities is out now :slight_smile: