English

Fairphone OS 17.07.6 (Android 6.0)

Glad it all worked out well!

1 Like

@rick: You released 17.07.6.1? Is there any changelog? :wink:
I’m no longer on FPOS, but maybe it’s relevant for some people. :slight_smile:

Since updating to the latest version last night, I’ve already had two sudden reboots. This has never happened before, so I’m pretty sure it’s the update.

Anyone else seen the same thing?

What do you mean? :slight_smile:

If you talk about Fairphone OS 17.07.6, the changelog can be found here: fairphone.com/release-notes, as mentioned in the opening post.

I’ve sent you a DM for your device UUID, this way we can look into the cause.

The download-site now links to 17.07.6.1. It linked to another location with “17.07.6” yesterday (I don’t have the link now, but my autobuild-server for rooted boot.img’s never lies! :stuck_out_tongue: )

1 Like

Worked without any issues, just let it do its stuff while I was busy with something else. Only a pity that the audio recorder is still not well usable…
Thanks anyway!

1 Like

Ah, like that.

We updated the manual archive to reflect the hardware support required by the new memory chip that’s in the new batch of FP2’s.

2 Likes

Hi there,

for months I was quite happy with my Fairphone in silent mode, as is was - silent.

Now, after a reinstall and subsequent update to OS 17.07.6 the shutter, screenshot and video start/stop noise suddenly reappeared. Like at the beginning of FP2, when only specific apps could disable the shutter sound - video and screenshot no included. Switching to “all silent”, i.e. “Alarm Only” does not help, the noise appears always in high volume. I even use the “Silent Mode Lock”-App - no chance.

Is there some regression / does anyone else have this problem?

If not - what can I do other than root / reinstall again?

Thanks for any pointers,

Alex

Interesting, tell us more about the new memory chip inside the new batch. Why was it changed? What else is changed in new FP2 Series? I know about the faulty SIM slots which were breaking a lot. They also change in newer versions, aren’t they?

Enabling Do not disturb (Alarms only) still disables the camera shutter and screenshot sounds for me.

Turning to silent and do not disturb works for me. No shutter noise

Hmm - I was afraid of that… so: what can I do? I think this means another day of backups, wipe and reinstall…

How about trying a reset of the cache and data of the camera app?

I get “System partition has unexpected content” error (Error 7) when trying to upgrade from 1.13.0.
There was a hint in one of the previous topics to re-apply 1.13.0 before upgrading to the current version, but I can’t find this option in Fairphone updater, even in advanced mode.
Any suggestions?

I just tried that - Open “Settings -> Apps”, delete Data & Cache of Open Camera, Camera MX and the built-in Android “Camera”-App. Still, only Camera MX can disable it’s Shutter sound, for Pictures only - Video still plays both start and stop sound.

I tried to find some changelogs in the code of FP Open on how the Update in April last Year accomplished the disabling of the sounds, but I didn’t succeed.

Funny thing: If I reboot, the Screenshot-Sound is silent in silent mode, Shutter and Video is not. After disabling and re-enabling Silent-Mode, all sounds play.

Anyway - I will try a complete reflash this evening, last time I only did a factory reset. If I find time I can check the logs first, but I doubt I am able to spot anything there…

1 Like

Ok. I downloaded the manual installation package, booted to fastboot, flashed the device, wiped Data, Cache etc. in Recovery and flashed again. I even tried Ubuntu Touch in between, so by now everything should be overwritten…

I then went though the initialization, got nagged by Google for resetting my device but still, only screenshots are silent in silent mode and only directly after booting, the camera is not. It’s an all-new FP2 experience now :wink:

I will try FPOpen next…

Is disabling the camera sound somehow regulated by e.g. the country the SIM card is from? I remember to read some weird stuff… I do happen to have a Japanese sim card at the moment…

I think I read something about this, too.

What if you remove the SIM card, enable flight mode and disable location, so that the phone doesn’t know any more, where you are? Does this change the behaviour?

2 Likes

Jep - just had to wait for the Phone to install (and the night to pass…). Indeed, as soon as I put the Japanese SIM card in, silent mode literally doesn’t exist any more. Mystery 1 solved, bonus points when someone figures out why it worked prior to factory-reset and updates.

For now, shall the endless power of root help me “scan” documents in office without disturbing everyone :wink:

4 Likes