English

Fairphone OS 17.05.2 (Android 6.0) is now available

But @Stefan also explains in his post that only the second patch level from Google contains all security patches. If Fairphone 2 is on “2017-05-01” and not “2017-05-05”, it would mean OS 17.05.2 does not contain the latest security patches.

@retsifp
Thanks a lot for your hint, the update worked like a charm (flashing the binary files). :smile:
No Data lost, everything like before :heart_eyes:
Flashed from manjaro linux

Greetings
Heinz

2 Likes

Is there a possibility to give my opinion about Fairphone OS 17.05.2, because I really liked the older version better… Or is there a way to go back?

What don’t you like about the update?

Mostly that the profiles for silence, vibration and sound have changed in what it is now… The rest is okay/good, but I really hate this feature, that I can’t have it on ‘vibration mode’ anymore…

There is a well written and informative article about that:

4 Likes

That is actually pretty helpful, thanks a bunch Gerry!

1 Like

Hello,

I can’t do the update. I just have a dead android with “error”. No number and I can’t do nothing. I have to unplug the battery to restar in the precedant version.
What does it mean? Why can’t I update?

Press Power and vol-up-button when you see robot to enter recovery menu and find more details about the error. (details regarding recovery mode you can find here: Dictionary Entry: Recovery Mode ).

To restart without unplugging battery: long press power (>12s).

1 Like

I followed instruction, and validate the update adb. It failed to.
E:Errorin/cache/fp_update_FP2-gms-17.17.05.7.zip (status 7)
Update aborded.

what am I supposed to do now?

And it says “no command” when I re tried

That sounds like the Android 6 recovery mode.

I use Fairphone OS17.04.8 and can’t do the OS 17.05.2 update
But I can’t do the update.
It’s frustating, my phone reboot for no reason, and more often when I use GPS. I NEED the update.

You could be a bit more verbose about what went wrong, but I presume updating this way should work.

It’s my 5th message… That’s why it’ laconic.
The update crash. I just have a dead android with “error” written. that’s all.
If I force it, I have a “aucune commande” ( no command).
I tried the way you suggest, but I fear I miss some knowledge : I unzip it and then… nothing.
I dont know where to click or what to do. I try boot.omg.p but it charged for nothing… and nothing happen.
thanks for the link

You downloaded the wrong file. Check my linked post for the correct one. You need the “manual” zip.

Have you really tried to “Press Power and vol-up-button” when you saw “dead android” with “no command” written? This should bring you to recovery menu and show more details about the error…

Yes I have. Several time.

I understand from your reply that you tried but the picture did not change.
Then follow in detail:
Press power button, keep it pressed, short press vol-up-button and release it. Then release power button.
That must bring you to recovery mode!

Fairphone OS 17.06.4 is now ready for download.

3 Likes