Fairphone OS 17.05.2 (Android 6.0) is now available

Depends :wink: .


Where can I find the change log. I updated today without problems, but I do not find any change log on the fairphone page, nor in the phone´s app,
thx for info,

You can find the release notes for Fairphone OS 17.05.2 here:

1 Like

Install Fails in normal and advanced Mode: I always get a Dead Android with Message “Fehler” (Error). No Error Number at all. Different WLAN (at home and at Work). Had to switch off by pressing 10 seconds Power Button (or waiting about 2 Minutes then the Phone starts by itself). I really don’t know why updates fail since Androis 6 (had also massive Problems when installing Androis 6). I Think i just wait till someone find a fix, today i don’t have time to test more.



My phone says the update takes aprrox 4 hours to install? Is this normal?

Kind regards,


A post was merged into an existing topic: Battery life after OS upgrade

Sorry to hear that you had that situation again.
As I said, it is not fixed in this update, beta-testers will see the fix in a couple of weeks.

It does not make the bootlooping-after-disabling-Google-App behaviour worse, it just did not change it. The same restrictions from 17.04.8 still apply.
If you decide to disable a system app, things might break as Android informs you.

Yes, it has been acknowledged with the April update but not everything can be fixed right away - we can only do so much at once.
Our primary focus is on monthly security patches. Whatever we have time to integrate in, we do. I am sorry you had yet the same problem though.


If you are talking about the download time, then it depends on your connection speed.

If you update from Android 5 (Fairphone OS 1.11 or Fairphone OS 1.13), the update file is about 500MiB.
If you update from Android 6 (Fairphone OS 17.04), the update file is about 200MiB.

Do you have any information (or at least hints :slight_smile: ) about FP Open 17.05 (aka Android 6)?


The current release notes can be found here:


Fairphone 2 cannot update to 17.05.2. Phone downloads the update, than restarts and after a short while gives an error message. I have to take out the battery in order to restart the phone. What can I do?

Thanks, Gerd

Thx. Those are the release notes for Google FP OS. I’m looking for any hint when the FP Open OS will be released.

1 Like

What’s the error message?

I just upgraded to this new release and now I’m having wild ghost-touch issues. Not the slightly annoying kind, where it would jump all over the screen while touching/dragging something (I had those too, in the beginning). But the kind where it basically seems to trigger/react to random touch events, although I’m not even touching the screen. I think the FP1 used to have a similar problem? Unlocking my SIM was an adventure…
Any ideas as to why this might happen and how to fix it?

Oops, obviously I read your post too fast, sorry for that! :flushed:

There is no new information, although some of us would like to see Lineage OS officially supported by Fairphone…

Thanks for tyhe quick response,

There is no error message, the green robot just lays on his back and it
says error. I tried it yesterday twice and today, always the same response.



3 posts were split to a new topic: Why is FP Open OS behind FP OS?

Hi @Gerd
i have the same Problem with the Fairphone Update, ist completely impossible. Just dead Android after reboot (see my message above). No Error number, just “Error”.
Everything i Tried fails with Dead Android :frowning:
I tried several different installations nothing helps

  • Normal Install -> Dead Android
  • Advanced Mode -> Dead Andoid
  • Download full version (FP2-gms-17.05.2-ota-from-1.13.0.zip) -> Dead Android
  • Reinstall old Version (FP2-gms-17.04.8-ota-from-1.13.0.zip) -> Dead Andoid
    Clear Fairphone Updater Cache & Data -> Again Dead Andoid

As I am not willing to reset my phone to factory default (the Working setup with VPN and everything else took me more than one day)i will probably stick with my initial Marshmallow version. I used my old xperia mini pro 4 years without security updates so i can live with that but i am a bit disappointed. The update Problem starts with Android 6 (also had massive Problems there). I never had the Phone rooted and installed every Update since i got my Fairphone (one of the first 17418).
If Someone find a solution i will try again but i don’t have the time to spend so much hours to get my phone working. I just want to use it.
Greetings Heinz

There’s no need to do that.

Install it this way. You somehow modefied your /system or /boot, I don’t know how but it doesn’t care. :wink:

My lock screen message now displays correctly, thanks a lot :slight_smile: