Fairphone Open OS Code that matches the released ROM

Continuing the discussion from Fairphone Open OS 16.05:

Yes. And no :slight_smile: Both is possible. You can just pull the lasted branch or all of different branches at once or even switch between them. Things like tags and branches can be very useful. That’s why a better documentation would be nice, so that even people that are not used to git so much can compile their own rom (with changes from the community, see the wiki/howto) quickly. I hope we will be able to document all this correctly in the wiki.

The right way to do this now (I have not check it yet) is to use @jochensp’s description. It looks like the right way. This should give you the code for the lasted branch that matches the latest released rom and the latest bin blob package. Normally I would update the wiki right now, but I haven’t tested it myself, so I won’t :slight_smile:

1 Like

I tried it. Just to let you know, it’s not working, yet.

error: Cannot fetch fp2-dev/platform/packages/apps/SetupWizard

Am I the only one getting this message?

$ grep -i SetupWizard .repo/manifest.xml

<project groups="pdk-cw-fs" name="fp2-dev/platform/frameworks/opt/setupwizard" path="frameworks/opt/setupwizard" />
<project name="fp2-dev/platform/packages/apps/SetupWizard" path="packages/apps/SetupWizard" />

Yeah, it’s not pushed (I told them in the channel already). As SetupWizard is not strictly needed, you can create a local manifext with:

<remove-project name="fp2-dev/platform/packages/apps/SetupWizard" />
1 Like

Thank you (also for notifying “them”). Adding this line helps getting the “whole” project except for the SetupWizard.

Currently make gives me

make: *** No rule to make target ‘out/target/common/obj/JAVA_LIBRARIES/tcmiface_intermediates/classes.jar’, needed by ‘out/target/common/obj/JAVA_LIBRARIES/ext_intermediates/classes-full-debug.jar’. Stop.

using the fp2-sibon-16.05.0 blobs, java 1.7.0 and a clean out/. Not sure what it causing this. I’m too lazy to look at the Makefile now. Maybe the file make wants to remake is just missing?

tcmiface_intermediates is part of the blobs, so it should be there. Either just run make again, maybe there is a missing dependency, or make sure you have the right blobs.

At least it compiled fine over here without the SetupWizard.

1 Like

I cleaned up everything a bit and now it started compiling here as well (not done yet, but looks good). I think I had too much old stuff laying around in the directories and that was confusing make. Thanks for letting me know it worked for you, else I would have given up way too early! :wink:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.