Fairphone Open OS 16.05

I couldn’t find it on my phone neither, but if you have F-Droid then it might be listed there as an installed App nonetheless.

It could be that the OS was made compatible with unified NLP (I seem to recall it initially wasn’t), but that unified NLP itself isn’t included directly.

It is working! Thank you so much!

Hi Folks,
I downloaded 16.05 using the Updater, then - when asked to - hit reboot. After a brief display of the TWRP wallpaper the phone booted as usual. I can’t see any change whatsoever, still running FOOS 16.04. My device is encrypted and rooted.
I’d be gratefull for any advice!

Same here, used Updater App, it asks for reboot, I reboot, get black Android screen with lots of grey text… it reboots and nothing has changed. Different to @mofi: not encrypted.

You could just download the OTA update file to your SD card, boot into TWRP and perform the update from there. This way it worked for me, although my phone is not encrypted due to the missing space at the end of the partition…

1 Like

Yes, you’re right. In F-Droid I see indeed that µg Unified Nlp (no GAPPS) is installed.

1 Like

I installed several backends to try it out on 16.04.0 without success btw. On 16.05.0 I never installed any backend, and GPS works perfectly without! Already integrated or something…

Hi, how exactly do I boot to TWRP? Is it the VolDown and On-Buttons?

No, when your phone is off, press Vol+ and On-button for at least 10s. Stop pressing them when at the back, the “Powered by Android” changes to “LOADING TEAMWIN RECOVERY PROJECT”. The wallpaper changes too but sometimes I don’t see the change.

Thanks @StephanK, this appears to have worked for me.

It’s only the support, you still have to install UnifiedNLP and a backend.

It’s not about GPS, but about localization from other sources, like GSM or WIFI. If you want that, you still need to install UnifiedNLP.


Received my FP2 back from repair last week, and now it’s awesome with Open OS. So awesome to see my dream of a usable phone with free software stack come true! (although there is still some room for improvement). Great suggestions here regarding UnifiedNLP. I’ll give that a try, because getting the initial GPS fix takes a very long time.


This is my feedback for Fairphone Open OS 16.05 release:

  • GPS location - fixed
  • Improved display backlight stability - fixed
  • Privacy impact - never noticed
  • Improved Bluetooth audio - never noticed
  • Screen flickering after boot up - still there
  • Time lost after boot - still there - When I drop a shell (via TWRP) and type $ date it is not set. Hardware clock?
  • Reboot or freeze while charging over night - still there but I suppose it is an Charger / Cable issue. Are there recommendations? My findings: charger with >=2A was never a problem.

Thanks a lot to the devs!

Rolf! :smiley:

I believe you are talking about a different issue: Glitching menus

Check out this wiki and please add your findings if they are not mentioned yet.

I don’t know how and why, but since I installed 16.05 my volume down button finally seems to work normally :smiley: I once thought the issue disappeared, but then very often it just came back and stayed… Finally I can make screenshots whenever I want, and not just when the phone allows it :sunny:

I still have problems installing the Update. I can open the Updater-App and download the software.

The it reboots (after asking) but switches to TWRP

I get this message, it reboots and was as before.

I did not change anything to the FPOSOS, just activated root.
Please help!

Update: same thing happens if I use the OTA.zip for the upgrade (from here).