Fairphone Open 16.12.0 is now available

Update done :slight_smile:
I guess there was a problem with the downloaded file, the first time.
Thanks again!

I had the blue wallpaper before (the regular one…), I just changed for a new one and I think that the phone app icon is much nicer on a wallpaper that is not blue, because you couldn’t distinguish the icon from the wallpaper.
I have the feeling that the new wallpapers copy the colour of the new covers (indigo, red, white).

1 Like

Update went smoothly here (using updater’s notification and then updater) ! :slight_smile:

1 Like

Update not working: Invalid file downloaded, wrong MD5
I read about this issue with other FP OS versions, but nothing helps. It downloads the file, then “Just a Moment” and the “Invalid file…” error afterwards.
I tried: Phone on charger; Emptying cache / data of the FP Updater app and rebooting; “stay awake” setting in Developer options; disabling Firewall etc. - nothing helps and I do not waste my afternoon downloading ~200Mb again and again.

Download the file on your computer and then install it via TWRP.

Thanks for the quick reply Paul, you caught me red handed - I am just doing this at the moment.

I am experiencing problems installing 16.11 or 16.12 after installing the update via TWRP and reboot my fairphone always get stuck at the black screen FAIRPHONE … with android.

As soon as I install 16.09 again which was installed perviously the phone starts again as expected.

Anybody any ideas how to solve?

This one took quite long, so long, that i indeed hoped they might skip it and prepare the 17.01. Well, also great they did not skip it, which shows they are committed to FP open OS, but according to https://www.xda-developers.com/android-security-update-for-january-2017-released-for-supported-devices/, it would be great if 17.01 would be again more timely. But only if it’s not impacting the health of the people preparing it, if I extrapolate from the interview with Bas…

New “fixes” for the random reboots actually made my FP2 reboot three times today. I only had occasional reboots before.

Also, I’m surprised the clock-bug is still not fixed eight months later (!). We even have enough developer info here in the forum:

https://forum.fairphone.com/t/fp-open-os-clock-resets-after-reboot/17635/78?u=roboe&source_topic_id=24895

I’m feeling dissappointed.

6 Likes

Hi guys,

I am kinda excited because I read about the new update by accident. My FP2 shows build OS 1.10.1 as current and up to date OS… No update to 16.12.0 visible…

Any ideas?

There are two versions of Fairphone OS:

  • One with google services included by default (FPOS). This version has version numbers that currently start with 1, then the update number, and then a sub-release number. The latest is 1.10.1.
  • One without google services, for which as much as possible of the source code is released (at code.fairphone.com), and is therefore referred to as Fairphone Open OS. The version numbers follow YY-MM-release number. The December 2016 update for the Open version is therefore 16.12.0.

Typically you’ll only see updates for the version that you have currently installed. If you have 1.10.1 installed, you therefore won’t get notified of the 16.12.0 update, as it is not an update to the version you’re currently using.

1 Like

Hi Johannes and thanks for the answer. I will assume, if I will switch to the none google version. As I am pretty connected to google this is not an easy but maybe neccessary step.

Thx again!

Other than the absence of Google services, there isn’t that much difference between the two versions. More specifically, the changes in 1.10.1 were later added to 16.12.0. In general the Open version even lags behind the regular version a bit (don’t be fooled by version numbers - there’s no relation between the numbers for open and regular). So the availability of an update for the open version isn’t by itself a reason to switch (and depending on you use scenario may even make things more difficult)…

1 Like

I see at least one more important difference between the versions: TWRP - the recovery system that is only available on the open version. With TWRP one can create backups of the Fairphone fairly easy - even to the external micro-sd card.
The reason why TWRP is not found on the “closed” FP OS version is that every official android release has to adhere by big G’s gagging rules - and one of these rules is that you are not allowed to ship the system with a custom recovery.
So even if you need some google functionality using the open version of FP-OS has advantages because you are not affected by said limitations. And I see it still as a form of “political expression” not to use software that has its architecture dictated by a corporation like google.
You can always install opengapps (http://opengapps.org/) if you need to install apps from the play store or you need some google functionality.
I have gone this route myself because there are some non-open apps I use. On my phone F-Droid is the main package manager, but google play is also there. And many google services are either disabled or blocked by the firewall.

2 Likes

Hi @Ronny_Frenzel,
If you are thinking about living without Google, there are two threads you might want to read:
A wiki:

And a long (but interesting) discussion, with many tips and ideas:
https://forum.fairphone.com/t/pencil2-living-without-google-2-0-a-google-free-fp2/?source_topic_id=24895

Good luck!

2 Likes

Hi Chrisse, thank you a bunch!!

Also thank you a lot! I am really not enough into the open G-Apps stuff. The thing I really know is that I want to avoid Google as far as I can just because of your argument. Does anyone know a structured information on these issues (what does Google do, how can I avoid that) in german language?

5 Likes

Hello everyone,
Is the mirroring working on with this new version?

Recently, I am experiencing difficulties with cellular data. Sometimes, my phone will loose cellular data connectivity, in locations where I should (and used to) have good enough signal. I can still make calls and send SMS, but no internet connectivity over cellular. Switching to airplane mode and back does not help, neither does switching cellular data off and on again. A reboot brings connectivity back, but that is a hassle.

I’m on FPOpen 16.12.0. With previous versions, I didn’t have these difficulties. Not sure this is related to the update or my carrier. Is anyone else experiencing this with the latest version?