Fairphone Open 16.11.0 release

All fine here (encrypted phone, without any gappsxposedwhatever), thanks :relaxed:

To flash with fastboot you need this things:

Windows-PC: fastboot / adb executables, Fairphone Drivers
Linux/MacOS: fastboot / adb executables

Please read the Fairphone fastboot manual how to install the drivers and where to get them.
If you press Vol+ and PowerOn you will get in to recovery (Stock on GMS / TWRP on Fairphone Open)
If you press Vol- and PowerOn you will get into Fastboot mode (FP2 shows only the logo in the fastboot mode)

If your FP2 is not regognized by the PC in the fastboot mode, most likely Windows Drivers for the Fastboot are not installed.

Fastboot is the most simple and best working solution to flash the FP2 IMHO.

But you need to follow the manual and install all necessary things that are needed to flash with fastboot.
Please read the manual again. You missed the drivers. I’m pretty sure

I use Linux Fedora 24. I had adb installed. But somehow I could’t get a good result. I have gapps installed now, as I needed a working phone

thats really weird. On Linux fastboot work like a charm. I have Debian Linux 8, installed 2 packages,
android-tools-adb and android-tools-fastboot

Start the FP2 in the fastboot mode (Vol- and PowerOn)
On PC start the script flash.sh (From the Fairphon Open Package)
You will see

Waiting for device

Connect the USB-Cable to PC (Direct USB, No HUBs)
Connect the USB Cable to the FP2, which is alredy in fastboot mode

You will se fastboot flashing the files from the Fairphone Open package

Very calm upgrade - two clicks, one reboot, no notable change on next reboot (apart from the new settings -> maintenance tool). Nice :slight_smile:

Have you configured udev-rules?

That’s probably where it went wrong. I have to look into this by the next update.

Thank you @Johannes. Your post helped me very much! Now everything is working fine :slight_smile:

Not an easy one:

  • 1st. attempt: Updater waiting endlessly at “Just a Moment…”
  • 2nd. worked after deleting data & cache for updater and flashing latest OpenGapps nano, but:
    Icons on the homescreens are completely messed up. Half of them is missing and I have to go through the pain to re-arrange everything.

Same here. Hints did not help (Install via fastboot and script)…

Also with me the update shouldn’t go without some special challenge:

  • When I try to go to the updater at both possible ways, I get the message ‘Fairphone Updater wurde beendet’ (=has been closed),
  • When I try to go to the Google Play Store, I get a similar message: ‘Google Play Store wurde beendet’.

This behavior started a day after the update. Before that I noticed, that I didn’t have a second (‘advanced’) screen for updating anymore.


Edit: Meanwhile I flashed the 16.11.0 version and the GAPPS-pico again, but the issues are still there: No admittance to the FP updater and to the Play Store.

Hello. I think I did exactly the mistake you pointed out. I forgot to copy the newest xposed framework version onto the phone. I flashed the old one and now my phone does not start. Now what is the easiest way to get the new framework-version onto my phone? Since I can not start it, it also is not recognized by my PC to simply copy it in the right folder.
Thanks for your help.

Take SD-card out and into the computer. Save the Xposed-Zip on the SD

Thanks Friek. This would have have been my first approach too. Unfortunately, I do not have a micro-SD slot on my computer. So I have to get it on the SD with the USB-cable.

Then you can either transfer the files via ADB (for this you may need to first flash the latest TWRP port), or use ADB sideload to install the xposed framework.
That is, you hopefully had USB debugging activated before starting the update.

Ok. I am trying to access the phone for a while now with adb (when I am in TWRP), but the computer can not find my device. So I guess, I did not activate USB debugging…

Then you can flash again the system.img from 16.10, plus the old xposed (and opengapps if applicable) to get again into your old system. This is how I proceeded when I discovered that the v86 xposed isn’t working with 16.11 (to wait for an xposed update …) :smiley:

@ Freibadschwimmer:
Thanks for the help. I actually have found a “dirty way” to get the newest framework on the SD. I put the microSD into my old garmin GPS and got access to it this way in the explorer. And it seems to work.
And I found out, I took the wrong cable to connect to the PC (only charger cable). Stupid! So I probably had USB debugging activated.

Nevertheless, how would I have flashed the old system.img? Is it usually on the phone somewhere?

Great that it eventually worked :thumbsup:

I guess there should still be a copy online, somewhere. Personally I always keep a copy of the last *manual-userdebug.zip on my hard drive; in case for troubleshooting (like this one) :wink:

No, your phone was stuck far before ADB started. The easiest thing (for the next time ;)): Reboot into TWRP and access the SD-Card from there. This works for me on Linux, maybe there are some special drivers needed on Windows (anyone?), but that’s how I always perform my updates (+ root + xposed) :wink: