Fairphone Open 16.10.0 is now available

Beware of file permissions. You may need to run adb shell chmod 644 /system/etc/permissions/platform.xml

That’s pretty easy, in fact. More docs here.

1 Like

The update to FP Open 16.10.0 went smoothly for me (my phone is encrypted, does not have the Google apps, or the Xposed framework).

1 Like

plain build in updater user - no real trouble during the update - just no real “visible results” - I do get the reported “clock time error” and I still have trouble with the calendar. It would help me a lot to know at least where to pose that kind of question - as apparently that place is not here on the forum.
[no random reboots so far, so the wrong time setting isn’t causing trouble - yet]

This two strange screens at the update module are gone and it looks o. k. now. But I didn’t change anything to get it right. Quite mysterious, this change!

I didn’t find any solution with problems with Google Play Store and F-Droid store, I described before. What I have found is another store “APKPure”, which offers a lot of apps you find at the Google Play Store, but not at F-Droid. But I don’t know at all, how trustworthy this store is. It also shows updates, if there are newer versions of installed apps, but I can’t update all of it. May be, that is because I installed these apps from other stores originally?

When I try to open the Google Play Store, now I always get the message “Google Play Store wurde beendet (= has closed)” and I can’t use it.
With F-Droid it’s the same as before. When I try to download an app, I always get the message “F-Droid ist abgestürzt (= has crashed)”, but with answering “OK” and a second try it works.

Any suggestions, what could be the source for this behave??? I already cleared the app cache and reinstalled the store apps, without success.

Try this. May be helps…

Try to uninstall F-Droip app and Download/ install a new file of F-Droid app.

I uninstalled F-Droid, loaded it down again at the desktop computer, transferred it via USB to the FP2 and installed it again. Result: Same error, behaves as before.

I’m also currently using Apkpure and, even though I’m quite happy with it, it would appreciate if someone could confirm it’s safety.

Since the update, I can’t connect my phone to my PC anymore. It only works, if I choose the “Mount SD Card” option, but then I can’t get to the internal storage anymore. Does anybody know what to do?

This usually happens to me when my OpenGApps version doesn’t match. Flashing the latest available version helped every time.

1 Like

Thank you very much, verasiegrid!!! What you recommended, I am shure, I did before, but without success. Today however it worked!:relaxed:

Again, it is better now, but not o.k… F-Droid works, but Google Play Store doesn’t: I can see and choose any of all the apps, but I can’t download or update any of it. The download process starts, runs and runs and runs and ends with an error message: “Download not possible” or something like that. Deleting the cache didn’t help.
On the other side: APKPure works.
Any other suggestions what I could try to get the Play Store running?

I have a cool side effect with the clock problem :grinning:

When I put the phone on flight mode and turn it off when I turn it on again, it can’t connect so can’t get the date right.

Result: I have unlimited lifes on Frozen game :wink: as the game seems to think it’s actually 1970!!!

So some good comes out of this very very annoying bug!


Sadly I have to say that I have frequent reboots since update 16.10

Try to follow this workaround guide: FP2 random reboots - see #rebootsguide for help

You can update the platform.xml in a save way manually from TWRP like described in 4b) of this guide: ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more)

Have tested everything listed in that post at least twice without luck. I have now been asked to send back my phone to get it replaced so I guess my phone is a lost cause. Support have really been fast this time so guess they really have worked their way through the backlog which is nice to see :slight_smile:

1 Like

I am back again here without a solution. I tried a lot of things, but nothing successful. Than I asked Fairphone Support and after some vain hints I have got the answer to ask here at the forum:

“For the rest I have to direct you to our forum, see below, as we don’t
officially support open source!
Unless its a problem with the hardware!”

It is obviously difficult to find out the reason for my problem, but therefore I asked the Support for help. The response, quite disappointing!
As I have read here, I am not the only one with this issue, some others are also left on its own with it.

Two ideas strike me:

My experience with this release: I have no problems updating from 16.07.1 to 16.10.0

Hi Antimailer,
thanks for your hints, but unfortunately it didn’t help. At the XPrivacy logs I have found a lot of remarks with the Play Store icon, but not the one you mentioned. Some others possibly suspicious (?):

  • accounts/blockingGetAuthToken
  • android.intend.actionPACKAGE_REMOVED

But I don’t know the meaning of these remarks, unfortunately.