Fairphone Open 16.08.0 is now available

Fairphone Open 16.08.0 release

Fairphone Open 16.08.0 has been released. You can get it through the
updater or by downloading (source and binary) from the website http://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html.


Fairphone Open 16.08.0 includes all the relevant fixes found in
Fairphone OS 1.6.2.

It also includes a firmware update for the baseband processor.


  • Initial improvements to the proximity sensor calibration which
    caused black screens when hanging up a phone call

  • Fixed inability to use extra USB storage (USB On-The-Go feature)

Security fixes * (Android public security bulletin from August)


(*)Security fixes:

CVE-2012-6701, CVE-2014-9863, CVE-2014-9867, CVE-2014-9880,
CVE-2014-9882, CVE-2014-9884, CVE-2014-9887, CVE-2014-9895,
CVE-2015-1593, CVE-2015-2686, CVE-2015-8941, CVE-2015-8943,
CVE-2015-8944, CVE-2016-2474, CVE-2016-2504, CVE-2016-2544,
CVE-2016-2546, CVE-2016-2842, CVE-2016-3819, CVE-2016-3821,
CVE-2016-3821, CVE-2016-3822, CVE-2016-3824, CVE-2016-3825,
CVE-2016-3826, CVE-2016-3830, CVE-2016-3831, CVE-2016-3832,
CVE-2016-3833, CVE-2016-3834, CVE-2016-3835, CVE-2016-3836,
CVE-2016-3837, CVE-2016-3839, CVE-2016-3840, CVE-2016-3842,
CVE-2016-3850, CVE-2016-4482, CVE-2016-4569, CVE-2016-4578,


…and I am absolutely disappointed that after all the discussions in these forums the clock bug has not been fixed - welcome to the 70ies again. This bug is hanging there for ages and nothing happens. People on “Non Open” OS do not seem to have this problem so I really do not understand why it takes so long to make something work that already works in another version.
I do appreciate the security fixes, but a working clock should get a higher priority in bug fixing than the USB OTG problems that this update should fix.


On the 13th of September there has been another software update ready for the Fairphone 2! It’s named Fairphone OS 1.7.0.
But the open OS users are only getting the equivalent for the OS 1.6.0 as the newest one, again!
On my FP2 the “Fairphone Updater” still says,that the “Fairphone Open 16.07.1” is “auf dem neuesten Stand”.

Does anybody understand this confusion?

1 Like

Start the updater again and at some point it should come up with 16.08. There might be mirrors syncing “out there”. I had the opposite problem of getting an update notice, but the actual 16.08 image was not ready for downloading. And do not confuse the version naming: 16.07 = July 2016, not FP OS 1.6.x. The only confusing thing is that the devs do not seem to stick to their own rules - this update should probably be 16.09.

Anyone else having trouble connecting to the storage.googleapis.com server? Just when I tried to download the 16.08 release…

Is TWRP gone? Or an ota update problem on my side?

After I have installed 16.08 successfully over 1h ago the updater is prompting me to update to 16.07.
Your current operating system version:
Fairphone Open 16.08.0

Update is available
Fairphone Open 16.07.1

Very strange world!

Download links at code.fairphone.com doesn’t work:

<Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message></Error>

The release is not available at the moment, there was a problem with the recovery image.
Fixed images are being uploaded shortly.
Apologies for the inconvenience.

1 Like

I just got what seemed to be good news on my FP2: OpenOS 16.08.0 is available. But when I tried to install the update the updater reports a download error and I cannot see anything new on the OpenOS webpage (code.fairphone.com).

Ok - I see it now appearing on code.fairphone.com. Maybe just a matter of mirrors syncing. :+1:
And now download and installation work as well.

can someone of the moderators remove this topic so it does not confuse people ? I just happened to get the update notification too early and everything works fine now.

1 Like

Well, for me it does not work well. The link “Download the latest version” at the Installation Guide ends with the error message:

Mit dieser XML-Datei sind anscheinend keine Style-Informationen verknĂĽpft. Nachfolgend wird die Baum-Ansicht des Dokuments angezeigt.
NoSuchKeyThe specified key does not exist.

What to do?
I don’t want to update an existing system but change from a just buied to Fairphone Open.

Looks like your browser cache is still pointing you to the old version. Try to delete your browsers (Firefox, Chrome etc.) cache and it very likely will work.

Unfortunatily that doesn’t work. And I got the same message on the new Fairphone, which should have an empty cache.

You are right, there is something very odd going on: I am getting the same XML error when I try to download the image and even more strange: After I have installed 16.08 successfully over 1h ago the updater is prompting me to update to 16.07.
Your current operating system version:
Fairphone Open 16.08.0

Update is available
Fairphone Open 16.07.1

Having the same issue with the broken links unfortunately…

The problem with the links exists at least for 4 hours now, I’ve been trying the whole (Europe) morning. I only had success with the manual installation package, which I didn’t want.

Obviously they are working on the file storage right now. Hopefully we don’t have to be patient too long :wink:

Does that mean that those who have already installed the release will have to re-install it ? And should this be the case will the updater handle this ? As I posted before the strange thing is that the updater wants to downgrade me to 16.07.

The updated images are now online.

If you updated using the images that were available only briefly, you will have to update again, as the image for recovery was wrong. The easiest way to do this is to use the manual image, extract the zip file, and flash the system and recovery partitions using the following commands:
fastboot flash system AP/system.img
fastboot flash recovery AP/recovery.img
And finally reboot:
fastboot reboot

I don’t think, that it was me, who mixed up something.

Providing a broken update that lags a month behind the “non open” version and that still has the annoying clock-bug is really not a way to encourage people to use free and open source software. I have no problem using “fastboot” aside from the time I have to invest that no one pays me for, but this will stretch many who have already updated. Why are you not just releasing a quick 16.08.1, that the updater recognises and everything can be easily fixed without fastboot?