Fairphone Open 16.08.0 is now available

When trying to install the update via the updater. It finishes to download, pauses for a moment and then aborts, saying “Ungültige Datei runtergeladen: Falsche MD5” (downloaded invalid file: wrong MD5). Mirrors still synching?

In the image

  • fp2-sibon-16.08.0-manual-userdebug.zip
    (sha256sum e2270cf62d507abba87f824e551af10547761c52041b111641235713590407d5)

is still the wrong recovery image (not twrp) deployd.

Tested with

fastboot flash recovery AP/recovery.img

I tried as well, with same result!

I did the “manual image” and got a file with the name of the obviously wrong zip-file. I suggest to give the proper file a new one, i. e. “…16.08.01…”. Than I would know, which one I should use.

That would probably even allow updating through the updater app. Two files with the same name and different content are always a bad idea.

Yes, too bad it’s not 16.09, but at least it’s an update… Hope they will soon catch up with the Google os

Update worked now - apparently the files and MD5sums on the mirror match now. Hopefully that was the correct version of the file. Would I notice if it was not?

The multi-user problem still exists with 16.08.

As a workaround you can remove /system/priv-app/FairphoneSetupWizard to fix the problem.


Updated from 16.07 without problem, no visible regression on the parts I’m using. Thanks for the effort of maintaining this Google-Free flavour !

updated from 16.07 open OS and it seems to work without any problem (but i didn’t try the calling volum issue yet, which is real with the former version).

13 posts were split to a new topic: Apps like waveup drain the battery

Hi All
Old bug, is back with this “update”…
see here…
Old Bug fixed in 16.06 is now with 16.08 back–>FP doesn’t charge, but freezes when turned off.

lg ivi

Hi everyone!

just wanted to let you know, that after the update to 16.08.0 I’m stuck in a boot loop: On every reboot the phone tries to “optimize the installed apps”. I suspect this has something to do with the pico gapps package I have installed.

Good that I backed up before updating…

Have you made everything according to the update guide for modified FP Open OS phones.


Thanks for your information!

No, I simply used the updater as I was used from cyanogenmod. I’ll guess I’ll have to try the complete procedure then.

Another satisfied customer here. The update went smooth through TWRP, my battery life has not decreased and WaveUp works again after sensor recalibration. :grinning:

1 Like

Same behavior here. Charging worked in 16.06 and 16.07 but not in 16.08.
Charging is only possible while the phone is powered on. Otherwise it freezes and I have to remove the battery.

The 16.08 upgrade was offered by the Updater app and went well.
Only after the reboot there was a strange popup showing my mobile number (see screenshot). I have never seen this before and it did appear only once.

I cannot confirm: I currently have a “Non Open” Fairphone at hand and the clock also didn’t survives the reboot and just fixes itself once the internet connection becomes available.


Update went smooth. I used the new manual method, after commenting out the dangerous fastboot -w line! :warning:. Could you please ask for the user input before silently wiping out their device? :pray:

After applying my patches (Needle for microG, AdAway, EmojiOne and increased LCD density), I was surprised to finally found fixed the screen blackout on boot and the proximity sensor issues. I hope the 16.07 exclusive random reboots are gone too! :pray:

Good work, guys! :smiley:

Maybe you could just pm disable com.fairphone.setupwizard via ADB (or from a root terminal)? (I don’t know right know what is the multiuser policy for disabled apps, it may not work)

Edit: no, it doesn’t work, I tried with a guest account, : /

Yesterday update via updater went perfectly. After shutdown in the evening I plugged in the charger. The led was red the initial screen (FAIRPHONE powered by android) was displayed and no charging display was shown. Even long pressing the power button didn’t switch the phone on or off. I plugged off for the night, the battery drained and tried again this morning with the same behavior of the phone. Now I removed the battery, plugged in the charger, put in the battery again and the phone started and charges. Do I have to let my phone turned on for a whole month waiting for the next update in order to be able to charge it meanwhile??? This really can’t be true…