English

Fairphone Open 16.06

Fairphone Open 16.06.0 has been released. It includes all the fixes found in Fairphone OS 1.4.2, fixes the charging mode and includes a setup wizard.

Highlights

  • Security fixes* (Android Public Security Bulletin from June)
  • Fixed charging mode
  • Setup wizard
  • Device stability improvements
  • Updated rear camera image sensor settings to reduce noise and improve general image quality

More

  • Introduced adjustable brightness for wallpapers (in Settings > Display > Wallpaper)
  • Fixed disappearing Portable Wi-Fi hotspot icon in Quick Settings
  • Fixed distorted Clock widget when using increased system font size
  • Fixed translation errors for several languages in the lockscreen Clock widget
  • Fixed the ownership duration in the lockscreen Clock widget
  • Fixed SIM configuration query loop issue with some specific MNO SIM cards
  • Improved built-in apps: Calculator, Email and Sound Recorder
  • Improved Fairphone Updater
  • Improved Fairphone Launcher
  • Changed behaviour of the physical camera button in video recording mode
  • *Security fixes: CVE-2015-3847, CVE-2016-0830, CVE-2016-0847, CVE-2016-2062, CVE-2016-2428, CVE-2016-2463 to CVE-2016-2465, CVE-2016-2467, CVE-2016-2469, CVE-2016-2474, CVE-2016-2488, CVE-2016-2489, CVE-2016-2494 to CVE-2016-2496, CVE-2016-2499, CVE-2016-2500
11 Likes

Nice! Thank you!

Could you point out the modifications for Device stability improvements in git for this one? Or just explain what it means? Thank you!

OHnooooo. HELP… Installed the update this evening. everything went smooth. After the installation, I went on to edit the platform.xml as usual to give writing permissions to the sd card( after every update, it is set to default)…I do not know if i made a mistake there or whatever happened…after restarting, nothing was accessible. no internet, no data seen on amaze…amaze shows no data on the sd card( the data on the sd card is still there when I mount the sd card), shows no data in the platform.xml( says it is empty) and shows no data in storage/emulated…so, basically i messed up with the platform.xml, i guess.
Tried the recovery mode to restore…nothing found to restore…so, I did a factory reset, which wiped all my data( I have a back up), but still same problem in amaze…tried installing the OS through fastboot…no chance…
Can not open browser…no internet…so, i cant’t even download Titanium Backup to restore everything…
What do I now do?
:frowning:

Could try to get into TWRP. Stop your phone, then power+volume up should bring you in TWRP. It will take some while, so have patience.
In TWRP clear Dalvik Cache and Cache partition.
Reboot
Try to run the updater again.
If you used GAPPS, you have to download GAPPS to your phone and install GAPPS by restarting your phone to TWRP, install and choose your GAPPS download.

On my phone the update to 16.06 went smoothly. I only had to reset the time.
Then I rebooted to go to TWRP, so I could install GAPPS again. Then I installed my Google account.

Is anyone experience screen tearing sometimes after a reboot (or random) on any version of Fairphone Open?
Any news on the “clock resetting on reboot” bug?
Or some random crashes (=kernel panics)?

It’s running well for me.

I’m really really impressed by the update frequency.
Bugs are being fixed, the latest security fixes supplied, user suggestions considered.

My previous sony and htc phones got 3 to 4 updates in 2 years (and where never :thinking: up-to-date let alone security).
My fairphones instead already got 3 updates in less than 6 months and are constantly being fixed and improved, that’s unbelievable! :sunglasses:

Right on guys, GOOD job! :relaxed::+1:

11 Likes

Thanks…I did eventually get the phone working…I overlooked a small thing during fastboot…So, Finally it did work. Restored everything from TB…however, I had to give it a couple of tries…restoring system data from TB was not helpful. Thus after playing with my Fairphone for 5-6 hours, finally have everything up and running as usual. :slight_smile:

Did you mean that?

1 Like

Yes, exactly that. Screen tearing in the lower left corner:/

I am. The related thread is here (include a workaround): https://forum.fairphone.com/t/glitching-menus-and-lists-after-boot/13398

Still not possible to deactivate the Sound Recorder. I use a different app, don’t need this one on my home screen.
(the above mentioned E-Mail and Calculator app can be deactivated)

Thanks! I will look if it happens in the near future.

Just curious: is it normal that you have to reinstall GAPPS (and fix a few other things - last time I think I had to re-import my Threema backup, reinstall GravityBox and XPrivacy, etc.) after every update? This is my first smartphone in many years, so I guess I’m comparing it with my computer, where updates don’t generally mean reinstalling but rather just a bit of time and then rebooting and voila, everything is back to normal.

On the one hand, I’m thrilled that Fairphone is so good about providing timely updates. On the other hand, the prospect of having to invest several hours every month to update and then get my phone back to the place I had it before the update seems a bit annoying/daunting…

(Note: I’m going entirely on the experiences with the last Update, Open 16.05. I haven’t actually updated to 16.06 yet, mostly because I haven’t had those few hours I’d need to get my phone working properly again…

If you use the default system (FPOS) you will not have to reinstall anything after an update. Basically you also don’t need to with FPOOS, unless you want to use software that is not part of the distribution.
In this case you decided to have GAPPS on your phone. The FPOOS update file wipes the system partition and reinstalls the system. Since your additions (GAPPS, xposed framework) are also written on the system partition, you need to reinstall them after an update.
So the reason why you have to do this is because you decided to modifiy the system partition.

3 Likes

Thanks for the quick reply @freibadschwimmer. So, if I understand your answer correctly, GAPPS are different from regular apps (which I haven’t had to reinstall, at least not most of them), because they go “deeper” into the system, i.e. modifying the system partition?

1 Like

Yes!
In that regard, that when you install an app, all files (from the app as well as your data) are stored on the /data partition (which remains untouched at an update). The Google framework (incl. play store), or xposed framework however needs to be integrated to the system (thus is stored on the /system partition), and serves as a basis for apps that you then can install on your data partition (all apps from the play store, also xposed modules like gravitybox).
Consequently when we reinstall the /system partition, we need to install these frameworks again.

However, it should not be necessary to reinstall any apps like Threema or GravityBox. For me it works when right after the update I flash the xposed framework and openGAPPS again. When I then boot into the System, everything works as before.

3 Likes

I may have done things in the wrong order last time - i.e. tried Threema and GravityBox before flashing xposed and OpenGAPPS. Will try again with this update, maybe that’ll do the trick then and require a bit less time. Plus - I get a little more practice with this whole smartphone thing each time, so in general it should be getting a little quicker :wink:

Hello everyone,

I updated today to 16.06. Unfortunately, I have a serious problem with this build: Normally, I have two accounts on the phone. After the installation of 16.06, I could no longer access the second account: logging in just led to a blank screen with a black background. The navigation bar just had the back button. May this be the setup wizard that is not displayed properly?
I did a complete reinstall - including one with fastboot - but the problem still exists. When I create a new secondary user (or a guest user) and I switch to it, I just get the black screen. I can log out by sending the phone into standby (just by pressing the on/out button) and then switch back to the main user. Sometimes, the navigation bar in the main user account has also the back button, but not the home and switch app button afterwards.
Have others also encountered this bug?