Fairphone bricked, Recovery aborts any access


recently I had issues with WiFi and Google Apps. Google Apps seemed to disconnect (gray WiFi-Symbol in StatusBar) and everything slowed enormously down, not to mention that no notifications were displayed. Nothing did Fix it (restarting Phone/clearing Cache of GAPPS). Anyway…
I started to update my 1.6 OS to the Android 4.2.2 Stock Version from Fairphone. Apperently the “FairPhoneUpdater” just restarted the Phone and deleted all Gapps. WOW ok, after I could not install any App properly anymore I tried to flash GAPPS using Recovery - every time I try to flash anything recovery just outputs “Installation aborted”. I tried this using sideload and Flash from SDCard. All failed. (1.6/1.8 OTA, 1.6/1.8 Image, just GAPPS and Cyanogenmod)
After that I tried to “root” my Phone (shouldn’t it be rooted already?) using MTKDroid - this also didn’t work (“adbd not installed”).
Strangely after trying this the folders “/system/etc”, “/system/app” and “/system/lib” changed their permissions to “rw-r-r” (missing execute) now I am totally stuck. I can’t boot my phone nor can I flash anything via recovery. ADB doesn’t work in recovery (which irony^^) and everything else needs a running device with Debugging enabled.

Sorry this text is very long, but I thought you might be interested in the way I bricked my Phone.
After all I ask you:
Is there any way - I mean literally ANY way - like something to completly wipe the entire Storage to get it running with any kind of OS? Do I have to write my own scripts? (then please help me, I’m not that deep into Fairphone-Drivers and it’s bootloader-structure. Even if I doubt that my scripts will flash…), Do I have to write my own recovery and have to load it via some cable directly to the Storage-ICs? Do I have to replace the Main ICs/the whole Motherboard?
I searched for a FastBoot-Mode for FairPhone but there seems to be none.
So please help me, I don’t want to put my Phone to waste just because these shitty drivers and the crappy recovery doesn’t allow any of the methods which worked for my Samsungs/Sonys/HTCs.

I thank you in advance,


Hello Flamm,

you fell for a mistake several users did before you. Stock Android 4.2.2 is not an “update”, but an alternative Android distribution. It is the unmodified version of the Fairphones OS as supplied by Google and MediaTek. Fairphone OS is based on that, add root, the Fairphone updater etc.

On the “Stock” version, there is no root and no installer for the GApps, however flashing through recovery should have worked. Anyway, you should not be lost.

Do you remeber if you had applyed the Fairphone Storage update ( Do you have the FP1U? Did your phone come with Fairphone OS 1.6 preinstalled?) This is important for the next step. You do not need the MTKTools but ADB and FASTBOOT must be installed. I suppose you know how to do that.

If i read correctly, you can still enter recovery mode? Do you have and SD-Card reader? You could use it do download an image of the Fairphone OS to your MicroSD card and then put that back into the phone.

Then head to the Fairphone support pages: https://fairphone.zendesk.com/hc/en-us/articles/201189497-Fairphone-OS-multiple-versions-
and download the correct image. Because there is nothing to loose, you could first simply try to install the correct image. If not, there is stillt the possibility to install and alternative bootloader and maybe there is a fastboot-mode hidden somewhere, but lets start with that.

Good luck!


There is CWM recovery, if you don’t like the “crappy recovery”. :wink:

Joking aside I want to point you to this page: Bricked your Fairphone? (XDA).



I am very sorry I didn’t explain myself correctly. I knew that the Stock Android 4.2.2 is not a normal update, but more a version without the “bloatware”. And thanks for the links, I visited all of them before - I researched about 6h straight to this problem but did not find any solution. I have ADB and FastBoot installed (but I don’t know how to set my FP to FastBoot, or is this the fast disappearing state called “Preload”?). Yes, my Phone came with 1.6 preinstalled, but I don’t know if I have a FP1 or FP1U - how can I tell which I have? My Phone displayed in “About phone” the Version FP1, but I bought it in the second batch so I guess I have a FP1U…

Yes I can enter recovery and I have every downloadable File on my SD-Card. I tried flashing everyone, but they all stop after 4 seconds, displaying “Installation aborted”. Same with ADB sideload - after transmitting ~ 5 seconds, then “Installation aborted”.

Also I tried to flash the CWM recovery, but same as before, if I try to flash it through ADB/Recovery-SDCard it returns “Installation aborted”. SP FlashTool could be a solution, but this isn’t for download anymore or you have to pay for it on a russian site - which I don’t like that much.

Is there any way to get ADB running normally while I’m in the recovery? If I select “update from ADB”, I am only able to sideload. I am hoping for some kind of FastBoot mode, or maybe there is a way with the SP-FlashTool :smile:

Thank you for your fast responses!


1 Like

On the xda-page about SP Flash Tool there is this download link, which links to mediafire. Not the best source I guess, but ways better than a random Russian page.

Does it work with this one?


You are welcome! :slight_smile:



after I tried everything twice, there seems to be no way for me to fix this problem. I managed to start the FairPhone in FastBoot (or a strange Chinese TestMode, where ADB can be used), but apperently there are Driver problems with my Computer. Also I got exceptions as I tried to get su permissions via ADB (“adb shell”), that there are missing .sh files on my Phone. These missing files are installed, but I removed the execute permissions I think. The SP Flash Tool doesn’t work for me, because of the above mentioned driver issues at fastboot / missing adb permissions.
Anyway, I am sending it to repair and hope they can fix it by replacing my Storage or Mobo.

Thank you for your efforts,


OK, please tell us, if they could help you! :blush: