Fairphone app crashes

Hello,

anytime I try to open the Fairphone app on the FP4 it closes after a couple of seconds. Anyone has an idea why that happens and how to fix it?

Thank you!

Did you disable Google services? This caused this crash on my phone in the past.

When I disable google play services I receive a message that a bunch of app wont work (including the Fairphone app).

Yeap it’s not a pleasant message :frowning:
However it is not actually true in some cases.

For example I get one that says the phone won’t work without it, but it does
and I don’t use the Fairphone app :slight_smile:

1 Like

So did you disable the Google Play Services? Then it’s quite obvious, why the Fairphone app doesn’t work.

The google play services app is always enabled on my phone, but the fairphone app was still not working. So, I tried to disable it and enable it again, in case something would change, but nothing changed.

Well the question was, whether you disabled the services, because that might be a reason.
So at the moment they are enabled?

So it could be worth a try to delete the app data. Long press the app icon and choose “App info”. Then go to “Storage & cache” and “CLEAR CACHE”. If that doesn’t help, try out “CLEAR STORAGE”.

You can always use these two if an app misbehaves, but be careful. While clearing the cache shouldn’t lead to any data loss, clearing the storage will totally reset the app. You will lose all data that isn’t backed up in any way, e.g. in a linked account (like it’s the case with “My Fairphone”)!

3 Likes

Sorry for the confusion… At the moment yes, they are enabled.

It happend the same to me. As @max_o suggested I deleted all the app data, forcing the app to ask for login again. Aftar that it went as expected.

Yes it worked again when I deleted all the data! Thank you!

Yes, I did the same now and it worked. Thanks!

The downside is that this is only temporary, in a few weeks the issue will return.

But do we know why this happens?

Not something we can control as far as I know. Also submitting tickets via the app doesn’t work for me. Even after clearing the data. Hope they fix it soon.

1 Like